Rust makes my PC run really loud, is this just because its in Alpha and has not been fully optimized yet?

My PC sounds like it’s going to take off and fly out the room. Lowering the settings and turning off the grass does nothing but the game runs smoothly at full settings anyway but the noise is a pain.

Is this just me or are other people having this as well?

If your PC is loud because Rust is the Reason,better take Components out of Plastic.So you dont have Problems with Rust.

Ok now to the Topic.Maybe you post your PC Components so we can say something.
First step at this point is maybe to buy a silent Fan.

I can say to you that i play Rust,have open Skype and Youtube and my PC is very silent.And my PC is now 3 years old



(User was banned for this post ("Image macro" - SteveUK))

Have you ever been so far even as decided to use go want to look more like?

I’m lost for words.

Once again


I think he was trying to make a Rust(i.e. iron oxide) joke about the OPs components rusting. But guessing by the wording and the lack of spaces after punctuation, he might speak english as a second language and/or not know that rust has nothing to do with plastic but more to do about moisture.

That is a common phrase from the internet to mock nonsensible sentences:

Ahh someone to see my joke.Ok,it was a bad joke i know.And yes,i´m sorry about my bad English.Its now 8 Years ago since i have to write in English :wink:

Why would that help?
He just needs to clean and/or upgrade his PC.

That’s all. Topic solved.

You are great.
I know that he needs to clean/Upgrade his PC.But maybe i would give him a Tip WHAT he has to do?
But its to easy to give a help,right?

I have the same problem. As soon as Rust loads, without even joining a server, my PC turns into a small jet engine. Any other game (such as Bf4) plays fine without trying to burn down my computer.

It’s your fans spinning up because your components have reached a certain temperature. Get monitoring software like CoreTemp for your CPU and MSI AfterBurner for your GPU and see what’s getting hot, how hot and if you can get away with turning the fan speeds down without causing damage. I usually aim for around 70 Degrees C on my GPU and around 50 Degrees C on my CPU.

If the game’s running fine for you you don’t need to upgrade anything.

Are you on a laptop? Make sure you’re running with the GPU and not the integrated graphics chip, which, while being power-efficient, can sometimes cause more heat and therefore the fans to speed up (it’s like that on my laptop)

I have Intel i5 3750k and AMD Radeon 7970, and i have the most best coolers, but still its actualy pretty loud

So you say its only loud if you play rust?Use the Programm ,Speedfan, to check Temperature and RPM.

Ah,i´m not a Fan from Radeon.After last Using one for Rust its overheated.But it was a 4 Years old Radeon,so i dont know how good this is.
In my Experience,Radeon have an loud Fan after reach an defined RPM.

I think its the Fan from your Radeon.

I have an Nvidia GTX 560ti, same problem. Only happens on Rust. It’s not a Radeon issue.

Specs? OP?

when I play older games on my gtx770 I hear a coil whine, this is whenever it goes above 1000fps in fraps in like, doom or something, very strange. Oddly enough, you could use that to make music by adjusting the pitch via messing with the framerate. That’s totally different though :v:

I do notice an odd sound coming from my rig when i run Rust, dont get it with any other game. Maybe im just hearing things…

The reason this is happening is because of two primary things: An open world game like this is continually loading a massive amount of assets and textutres so your video card fan is kicking in to max because of GPU heat. This is a good thing and although you can manually set the fan speed to about 50% it would be better to keep it automatic. The other reason is because the same assets and textures are constantly being pulled off your hard drive as you move around the world, so as the disk spins to read data it makes that churning noise (unless you have an SSD).

Try running the game on lowest quality when you launch it to see if the sound changes. Check your video card driver settings by right clicking on windows desktop and choosing “Catalyst Control Center / NVIDIA Graphics Properties”. Otherwise search for a manual fan control program for your specific video card (ATI/NVIDIA).