People can't download.

I made an RP server, and when people join it, it says its downloading all the lua, addons… etc.

but when they join, all the files they just downloaded don’t go into affect (they don’t work)

if they join the server again, it downloads all the files again, and same when they join again.

I tested this myself, and moved my garrysmod folder, and started fresh, when i joined my server, nothing worked, only if you already have RP, but if they don’t, or don’t have the custom lua files or the addons, nothing is there.

This is on a dedicated server btw. Anyone know whats going on?

Personally I dont know whats wrong but I have encountered this myself and it is very frustrating because i can spend aprox. 10mins downloading for a server then when it finnally sends client info and says, error you dont have the stuff that you just downloaded, lol? This would be very helpful if someone fixed it.

Try creating a fast download server. (Just a guess.)

can’t when its dedicated.

try use hamachi with your friends when u make server this may help, but i am not totally sure this works for you but it does for me