Performance on Rust

Hello everybody,

This month, i’ve bought a new laptop and my game doesn’t work , i’ve 17~20 FPS on simple. And when i see a campfire my FPS down i’ve 12 FPS approximately.
I know it’s a early acces games but i don’t know why with my config i can’t play.

I share you my configuration:

OS: Windows 10 Professional 64 bits
Processor: Intel Core i5-4210H (dual-core) 2.9GHz with Turbo boost to 3.5GHz
Ram: 8Go
GPU: Nvidia Geforce GTX 950M

Thanks for reading,

Yea, I’ve been having troubles with optimization also.
Have you tried disabling shadows? I heard it helps a lot.
Command (f1 to console in-game) - graphics.shadowdistance 0

Make sure Rust isn’t using your Intel’s HD Graphics. Even though your CPU is classed as “high performance graphics” it’s not cut out for graphically-intensive 3D games. Your CPU is also a little weak for a gaming CPU, as it’s only dual-core with hyperthreading. The 950M is also not the most powerful video card for gaming, so you’re only going to be able to get so much performance out of it.

However, Unity games love glomming onto the Intel HD instead of using discrete graphics on laptops, so that’s probably the real problem.

Also make sure you turn things down in the F2 graphics options. By a LOT.

@Colorado I try to disable shadow, and i tell you if it works.

[editline]15th August 2015[/editline]

I play on Rust and i can see the game it’s very weird on my pc, because when i play in Fastest i’ve 20, Simple 20 FPS and Fantastic 20 FPS what ?? Do you know what is the problem ?

Up !

Make sure in your Nvidia control panel, that you are using the 950M and not the Intel HD GPU…

Since I’m not allowed to post google search results here… u need to find it out yourself

don’t bump pointlessly, do what has been suggested and tell us if it worked. ie check if the game is using the intel or the nvidia gpu by pressing f1 in game…

Ok so In-game when i do F1 and when i click on check system information my GPU is Intel HD Graphics 4600, so do you how can i change this ?

I think this is just a spec listing mistake/error, you’d be getting MUCH worse performance if your laptop was using integrated graphics.

Right-click on the desktop and set the default graphics adapter to be your Nvidia card.

Ok so, my problem it’s fix, thx everyone, now i can play in Beautiful ~ Fantastic with 50~60 FPS

Thanks community for yours help