Permanent Fullbright in some HL2 maps

Several of my L4D models were pitch-black, so I added the -dxlevel 81 into the Set Launch Options window.
Now, some of my HL2 maps are permanently in fullbright, despite repeated input of the mat_fullbright 0 command.
Any help here?

This thread here might have some advice.