PermaProps migration issue

Hi there,

I migrated my Garry’s Mod server between hosts yesterday and copied the addon folder for PermaProps to my new server - however the PermaProps are no longer spawning on my new server and the PermaProps tool is not shown in the Q menu.

I have tried: Copying over my sv.db, restarting etc.

If anyone knows how to fix this issue, please let me know.

Thanks a lot!

Mason

Total guess: PermaProps uses a file in the garrysmod/data/ folder to store information, check there?

No, there is no folder for permaprops in there, thanks for trying though :slight_smile:

Just to make sure, you’re using this permaprops, right? It looks like moving sv.db /should/ have done it, but can you post the output of this console command?



lua_run PrintTable(sql.Query("SELECT * FROM permaprops;"))


So it looks like they are in the DB…it just doesn’t spawn them :confused:

Thanks for trying to trouble shoot this further with me :slight_smile: -P.S. that is the correct version of permaprops which you linked :slight_smile:

Sure!

The last thing I can think of is maybe game.GetMap() is doing something with capitalization between your old and new server, if you do



lua_run print(game.GetMap())


does it print anything other than “rp_downtown_v4c_v4” or “rp_eastcoast_v4b”?

It prints ] rcon lua_run print(game.GetMap())
> print ( game.GetMap ( ) )…
rp_eastcoast_v4b

So, this should not cause an issue…however, the command line which starts my server is this: http://prntscr.com/gbtbjy I wonder if the "s could cause an issue?

Before I migrated my server, the commandline didn’t include these, I will contact my host and see if they could get the "s removed. I’ll let you know the outcome. :slight_smile:

[editline]22nd August 2017[/editline]

That doesn’t seem to have fixed the issue :confused: Any more ideas? Thanks again.

I’m afraid I’m out of ideas, maybe try submitting a bug report on github and see if you can get some help from the maintainer. https://github.com/MalboroGmod/PermaProps/issues

Yo dude, I’ve looked into it further and I think there may have been a conflict between PermaProps and another addon which I think I have now solved…however it is giving this error on server start:

[ERROR] addons/tool_permaprops/lua/weapons/gmod_tool/stools/permaprops.lua:174: bad argument #1 to ‘SetCollisionBounds’ (Vector expected, got number)

  1. SetCollisionBounds - [C]:-1
  2. PPEntityFromTable - addons/tool_permaprops/lua/weapons/gmod_tool/stools/permaprops.lua:174
    3. fn - addons/tool_permaprops/lua/weapons/gmod_tool/stools/permaprops.lua:297
    4. unknown - addons/ulib/lua/ulib/shared/hook.lua:109

Any idea what this is telling me?

:slight_smile:

It’s telling you that in addons/tool_permaprops/lua/weapons/gmod_tool/stools/permaprops.lua on line 174, the call to SetCollisionBounds() is doing something incorrect.