PERP Issue

Hello, I have revived a PERP issue, when I try to join I get STEAM_ID_UNKNOWN which I believe is preventing me from joining the server. (security.lua) All my moudules are up to date. When you join you get stuck on the loading screen, in the server console the chat gets spammed with loading the account from the db.

Do you have a MySQL Server and edited the MySQL config for PERP?

Yeah, all modules, tables eveyrthing is connected

Have anyone else tried to join the server? (Just to make sure it’s not only an issue applied toyou)

I think gatekeeper is failing to get the SteamID on player join

Will it ever be updated/fixed?

Not sure, you could alter the lua to load their user on PlayerAuthed hook instead.

I’ll try that then

Try adding this to your server cfg



gk_force_protocol_enable 1
gk_force_protocol 21


gk_force_protocol_enable 1
gk_force_protocol 21

That worked for my ass_security.lua problem in plugins. Now theres some other problem. When I load the gamemode I still get spammed with Loading <Playername>… and I have all the stuff in the sv_hooks. I am stuck at the loading screen basicly.

Would help if you gave the error provided in console.

I have no idea what it is it just spamms loading the account info from the database which it doesent

Mind showing screenshot?

do you have the libmySQL.dll in orangebox/

bingo ^

Now, I get [gamemodes\perp3\gamemode\sv_hooks:16] attempt to contaenate field 'ServerIdentifier <a nil value> <Hook: Initilize> i

I dunno, ask VoltageGaming (the creators of PERP3)

Wasn’t VoltageGaming’s domain bought by the guy who ran PioneerGaming, which then lead to them using the name for it’s reputation? The only person from VoltageGaming’s higher administration was Skyline.

Anyways, GM.ServerIdentifier isn’t being defined.

Also me.

Check GM:Initialize on line 44 of sv_hooks.lua

You need to place serious.txt, lite.txt or dev.txt in the root folder.