Phong Issues?

Well, this might be from the latest update (which apparently ‘broke’ GMod, but at least it seemed to work for me), but I still think it might be worth asking for information, since the last issue I had with Half-Life 2 maps was related to a mistake by Valve, not GMod.

Basically, this happened:

http://img820.imageshack.us/img820/412/d1eli010037.jpg

I suspect it might be related to phong, seeing as it’s affecting only materials where phong is applied.

Anyone know how to fix it? I was hoping to get some posing done for a comic…

It’s very strange. What’s that?

Basically, it makes phong (or something else I’m not aware of) look like extreme cel shading. Am I the only one getting this?

You’re not the only one.
http://www.facepunch.com/threads/1079108-Yo-Garry-what-s-with-the-funky-L4D2-SI

Hadn’t seen your thread, sorry. :confused:

It’s clearly phong, otherwise it wouldn’t just apply to Eli and Kleiner’s heads.

Borderlands in Source Engine.

I’m obviously going to be banned from being ungrateful for a brand new feature of Garry’s Mod.

Kidding aside, it’s a bit bothersome, because I was going to make some poses in a Half-Life 2 comic. If it was more subtle, this “effect” would be great on other comics, but not a serious HL2 one.

I’m not getting that, but the models are a bit too much on the phongy side for my taste.

Try mat_specular 0 into the console. Might wrk though might not. My guess is that the new phong shader is somewhat more demanding than the old one and your card just isn’t capable of rendering it correctly.

:what:

[editline]17th April 2011[/editline]

The GeForce GT 120 may be a piece of crap, but it’s not a crappy piece of crappy crap.

Does it happen in CS:S, ep2, hl2 etc?

Same thing happens to me only white instead of black. Just Garry’s Mod for me AFAIK.

I’ve seen helmets that are too shiny in DoD:S. The Combine soldiers did not have that bright phongy film on them in HL2.

[img_thumb]http://i56.tinypic.com/f36g7k.jpg[/img_thumb]

Most of the models I use in Gmod, whether it is from CSS or DOD, are overly shiny. Too much phong. I’m on a GTX 580.

I haven’t tried other OB games.

Overly bright phong shading here too, on an Nvidia 570 GTX with fully up to date drivers.

http://cloud.steampowered.com/ugc/540639762160932061/312DFAB95E0E74FECB0BF2407A699FCE07BE5A43/

Also the Ep2 blood effects have been replaced with the TF2 particles.

http://cloud.steampowered.com/ugc/540639762123282423/07A9D4D8A36E7E30511189B2CE8F43AA5213FB79/

I’m also getting a lot of missing sounds like the hunter screams and walking sounds and the jalopy’s engine.

You know, I’d like to think I’m not stupid enough to forget to check that out, but, alas, I really am that stupid. Sorry, Garry; let me just check it out, and I’ll edit this post with the answer.

EDIT: Tried Half-Life 2, it works as perfectly as usual. So it’s not an engine issue, it’s really just Garry’s Mod.

And also, to Piett:

You’re forgetting that the engine was updated. Combine soldiers have phong now.

It’s safe to say a lot of people have this problem - it’s easy to see if you own portal - open any map in gmod (though the map where the phong problems are most visible is _a_testcmbr10 - especially on portal cubes and chell’s hair) and spawn a prop with phong materials. The phong materials instantly turn white on the sides if an observation area (the places behind glass with monitors and chairs inside) is close by, and has a distinct red hue if movable panels are nearby (for example the elevators).

Phong has also been messing up for me as well.

i have the same problem

I am having the same issue and it is getting quite annoying. I even deleted and reinstalled my gmod and still no fix. I am so confuzzled…

I am using
NVIDIA GeForce GT 330M and Intel HD Graphics. Very good quality stuff for what I need. Able to run all other source games super smoothely at the highest settings possible. Shouldn’t be a graphics card issue.