Phymodel problems.

My phymodel looks like this in HLMV:
http://puu.sh/6FZh9.png[/t]
And it’s supposed to be like this: [t]http://puu.sh/6FZds.png

That’s my QC:


$modelname "kp_dog.mdl"
$model studio "dog.smd"
$cdmaterials "models\kp_dog\"

$hboxset "default"
$texturegroup "texturegroup"
{
{ "dog_001" }
{ "dog_001p1" }
{ "dog_001p2" }
{ "dog_002" }
{ "dog_002p1" }
{ "dog_002p2" }
}

$attachment "Penis" "Penis" 0.00 -0.00 -0.00 rotate 0.00 -0.00 0.00
$collisionmodel "phymodel.smd" {
	$concave
	$mass 90
	$inertia 1.00
	$damping 0.00
	$rotdamping 0.00
}
$surfaceprop "flesh"
$illumposition 1.866 -0.053 36.320
$sequence idle "idle" ACT_IDLE 1 fps 10.00



Have you followed these steps from the sdk wiki?

*Use the Attach function to combine every part into a single editable mesh.
*Do NOT weld vertices together after using the Attach function. All objects within the mesh should be individually selectable using the “Select Element” option within the Edit Mesh modifier.
*Select every element (in the mesh) individually and set them all to a different smoothing groups. (If the elements don’t touch you can set them to the same smoothing group, I normally use different smoothing groups unless I am working on a very complex collision model and I need more than 32 objects).
*Apply your model’s material to the collision mesh with at least a basic UWV map.

Since it’s a rigged model you want to use collisionjoints as opposed t ocollisionmodel.

Also throw out the hitboxset default line while you’re at it.

You seem to be using Max 2009 Version -_-…

I use 2012, and my phymodels are whole models and its working fine. (Of course, its not a whole model. its cut into pieces. but its a whole mesh… I DONT KNOW.):suicide:

Well, I’ve smoothed my Collision mesh and replaced $collisionmodel with $collisionjoints.

http://puu.sh/6GQxA.png

Oh well, it’s because of a bad rig.
Fixed now.

http://puu.sh/6GR17.png