Physgun & Gravity Gun

I’ve already disabled all of my addons and then restarted the game. It did not fix anything.

I’ve had this issue for a while now, and have absolutely no idea how to fix it. The game’s texture for the physgun is how it should be, but it looks terrible in-game for some reason.

And no, it is not because it has to have the possibility to change color. I’d just disable it if it were my choice.
Also as you can see, my chosen color is blue (close to the default) and it shows up as white.

http://img515.imageshack.us/img515/8564/54010549.png

Also, this is a rather minor issue, but when I install a new addon and load a map afterwords, the gravity gun loses all control of its textures.

http://img198.imageshack.us/img198/7932/39235784.png

As always, any help would really be appreciated.

  1. Validate your GMod files by right clicking --> Properties --> Validate Integrity of Game Cache
  2. If that doesn’t work, follow these steps. http://forum.facepunch.com/showthread.php?t=1271741
  3. If that once again does not work, delete your Garry’s Mod folder (or rename it garrysmod_old if there’s anything in there you would like to save) and reinstall.
  4. If all else fails, validate the files of HL2 and episodic content.

One question, did you unsubscribe from all the addons or just disable/delete them?

I’m gonna go ahead and say it’s probably steampipe, I get that same problem (with the gravgun, Black boxes) with my AR2 Combine Balls.

otherwise, I agree with what code_gs suggested, Try those.

Not sure if I’m illegally bumping here, but I disabled them. I have way too many addons to go through and unsubscribe from each individually.

Ok, did you follow my steps?

I did all four steps, no luck with anything.

I guess just wait 'til 165 to see if anything is magically fixed. If you tried deleting your folder and it still did not work, I’m stumped. When this happens, try looking in console. Is anything error wise in there?