Physics Gun freezing problem.

Recently, for what ever reason the Physics Gun won’t freeze like it used to.
Before i could hold the object then just click to freeze, and when i let go of the freeze button, even if i was still pressing the primary attack button it wouldn’t go back to dragging the object.
Now when i let go of the freeze button it goes back to holding the object, meaning I have to hold the freeze key, look away from the object, then let go…otherwise it goes back to dragging the object.

Tried a few things to fix this with no luck:
Attempted uninstalling -> deleting Gmod folder
Attempted changing the keys to see if it was a mouse problem.

Problem only seemed to start after I installed an addon earlier this week, though uninstalling/deleting folder should have solved the problem.

Couldn’t seem to see any other threads about this…so i’m guessing it’s not something in a new update.

Any help with this would be appreciated. =D

Edit: Also wanted to note, a friend of mine that was in the same server seems to be having the problem aswell.

Same thing happens here. I’m guessing it was an update that broke it.

There doesn’t seem to be anything about it in the patch notes though: http://wiki.garrysmod.com/?title=Patches#2010

I’ve had no problems.

I’ve got the same issue, hah thought it was just me having fumbly fingers

Same here

http://www.facepunch.com/showpost.php?p=23378846&postcount=1411