PhysModelParseSolid failed

I’m creating client props with physics. Everything works like it should except I have this message in my console:

https://dl.dropboxusercontent.com/u/10892189/Screenshot 2016-04-19 03.29.09.png

*C_PhysPropClientside::Initialize: PhysModelParseSolid failed for entity -1.

*It happens every time this code is run:



local prop = ents.CreateClientProp()
		prop:SetModel(self.Shell)
		prop:SetPos(vm:GetPos()+vm:GetAngles():Right()*self.EjectPos.x+vm:GetAngles():Up()*self.EjectPos.y+vm:GetAngles():Forward()*self.EjectPos.z)
		prop:Spawn()
		prop:SetAngles(ply:EyeAngles())
		prop:PhysicsInitBox(Vector(-10,-1,-1),Vector(10,1,1))
		prop:SetSolid(SOLID_NONE)
		prop:SetCollisionGroup(COLLISION_GROUP_WORLD)
		prop:SetModelScale(1+self.ShellSize)
		local phys = prop:GetPhysicsObject()
		phys:Wake()


The only other place I’ve found anyone having this issue is in this thread starting with this post.

I tried changing SetSolid and PhysicsInitBox. Even tried different models. Not sure what else to try. It doesn’t seem to be causing any issues other than spamming the console. Which is why I’m posting.

Anyone else ran into this and came up with a workaround?

That’s odd, no errors for me- are you sure you’re not doing anything else to the entity?

I’m adding force and stuff later in the file, but I commented everything out and just left the code you see in my original post and it still does it. It started doing it before I had even written anything else and I assumed after I defined the rest of it’s properties it would quit. It did not. Did you copypasta my code and get no errors, or did you write your own? Was it in the base gamemode or sandbox? It’s probably going to come down to something stupid simple.

It’s wrapped in a function that I’m running from PostDrawViewModel(). I tried running it from a shared function and no dice. I’m also working off a dedi on my local machine rather than singleplayer.

EDIT: I suppose it’s not that big of a deal. I’m just OCD about errors. It only shows in developer mode btw.

Well, I copied it and changed it a bit to this so it’d work:



local prop = ents.CreateClientProp()
prop:SetModel(LocalPlayer():GetModel())
prop:SetPos(LocalPlayer():GetPos())
prop:Spawn()
prop:SetAngles(LocalPlayer():EyeAngles())
prop:PhysicsInitBox(Vector(-10,-1,-1),Vector(10,1,1))
prop:SetSolid(SOLID_NONE)
prop:SetCollisionGroup(COLLISION_GROUP_WORLD)
prop:SetModelScale(1+1)
local phys = prop:GetPhysicsObject()
phys:Wake()


And yes, I tested it in sandbox cause I thought that was the base gamemode :v: