Player Join Crash at Random

Just like the topic says, I’ve noticed that every time someone joins, the server crashes and it’s random.

I’ve seen 2 topics about this but lead me nowhere.

I’ve read that it has something to do with sending too much lua, assmod, wiremod, or too many addons.

We have like only 28 addons and that’s not as bad as the some of these other servers that try to get all the addons on garrysmod.org.

I’m just trying to get spacebuild 2 working on my server.

From what i heared it’s ULX version difference between client and server. If you’re using ULX on your server ofc.

No, we use Assmod and lately we switched to Spacebuild 3 and it seemed to work but we wanted CDS with the munitions in it to work, but so far I have not been able to carry it over.

Since one of the recent updates assmod has been a bit glitchy and caused either servers to crash or not allow people to connect.
I had this issue on my server, once i deleted assmod both problems were fixed. Since ULX may also be a problem ( thanks for the tip BBOOBBYY! ) I would recomend Newadmin.

Is it just a conflict with Assmod and Spacebuild? Because we used to run a DarkRP server and are still running a Flood and Onslaught server with no problems with Assmod.

If so I will ask the Owner of the servers to consider switching to NewAdmin or ULX.

I heard that if someone joins the server creates any Table for files the client has to download…
And this table won’t be deleted after the client joined and so the table gets bigger and bigger and than the server crashes…

So Spacebuild 2 makes unusually bigger tables than any other gamemode?

Because we used to run Flood, DarkRP, and Onslaught from the same directory without a single “player joining” crash.

Were having the same issue on spacebuild 3 servers… :confused:
Annoying…

Make sure you don’t have too many addons on your server. There is a limit remember.

I have seen this too.

Are you sure? Cause I’ve seen servers out there that are packed with dozen upon dozens of addons with no problem…

Maybe we shouldn’t have too many BIG addons like Wire, PHX3, SBMP, SB2, LS2, RD2, RTS, CDS, GCombat, Gas systems for LS2, Petrol mod for LS2 and Assmod (maybe)

And link me to a site that says there is a limit >.>

Apparently this is a gmod bug, someone showed me a bug report that avon made or something. Can’t quite remember if it was solved, but it was along the lines of this issues I think.

Yea, I saw that too.

http://bugs.garrysmod.com/view.php?id=1001

Just thought that someone here would know a fix and didn’t know about the bug tracker.

Don’t play DarkRP.

It’s really hard to find a DarkRP server without:
-DeathMatch
-Admin abuse
-12 years old admins and / or server owner
-Prop killing
-Mic spamming (with annoying kid voice)
-Blocking the spawn with props

I’ve never seen anyone roleplaying on DarkRP.
But I’ve seen people roleplaying on CakeScript (which is public), TacoAndBanana, PERP, GModRP.
The reason why people are not roleplaying and doing the list of things above is the script itself.
DarkRP forces people to DeathMatch and Prop Kill.

The updater himself (FPTje ) never roleplays, and instead he Prop Kills and Minges on the gamemode he’s updating !
I went to a server with FPtje on once and got spawn prop killed by him
Here’s a video that proves it:

1:43 - He even admits that he’s a MingeBag !


(User was banned for this post ("Spamming" - Rusty100))

I know the reason for this because I had this once, make sure your server doesn’t have any addons that spawn NPCs without going to the NPC Spawn menu…

Example : NPC Spawner stool and Headcrab canister stool

If you have them… delete them.

And you can have as many addons as you want… It doesn’t matter.
Only NPC Spawners cause this problem (includes !maul command from ULX If I’m not mistaken).

If you have deleted them and It still doesn’t work then I can’t help.

Edit :

You can even have 100 big addons.

Don’t know what that has to do with Spacebuild but alright. (and that video is about that new game mode right? The one that is based on prop killing?)

-to everyone else.

We found out what made it crashed constantly and removed it.
It was the Tiberium mod and Tiberium Harvesting mod we had on there.
We removed it and there were no more “player join” crashes.

Oh I remember that mod… I always hated it… (jking)

Well, good to see you fixed it :smiley: Congrats!

If you’re running Wire on these spacebuild servers, ensure you remove the gpu library stuff and whatsnot, that will most likely solve any problems. Also, ensure you’re running nothing “useless” and “unused”, as spacebuild is horribly inefficient and laggy.

I know this is an old thread but it dosent seem to be solved, I’m getting the exact same problem (after about 4-6 players)

We’ll i looked around a bit and i believed found the problem. In the console, just before a join crash, a massive list is generated of all the lua files on the server. If this list counts more than i think about 1024 files it produces an error and crashes the server. This, is the string table, the mighty enemy of massive addons. Basically, from what i can tell there are too many lua files on the server and it overloads the string table, causing a server crash. The only known way to solve it is to remove the massive addons like Wire, Stargate, SpaceBuild, Gcombat, and anything else with lots of lua files. Unfortunatly, this big addons also happen to be the most fun. Of course there may be another option: Raise the max amount of files the string table can handle, but I’ve got no idea how to do that and it even may be hard coded in the source engine. For now we can only hope Garry gets his act together and fixes the problem, or that the developers of the major mods concentrate the amount of lua files.