Player nextbot f*cks up ULX commands

Hello, I tried to use a permbot function(dont ask why) on my server, and the problem was, commands like ulx kick(!kick) and such didnt work, but !fspec and !rcon worked fine?
Now, I dont want you all to discuss why I want a permbot, no, its not for “luring” players, so please, dont discuss.
thanks for your help, here is the code snippet which caused it:


CreateConVar("ows_permbot", "0", nil, "Adds ONE permanent bot to your server, which got godmode, good for TTT spectator.")
local function perbotcreate()
	local pb = player.CreateNextBot(settings2.botname)
	pb:GodEnable()
end

hook.Add("PlayerInitialSpawn", "Cus I am dumb in coding", function()
	if GetConVarNumber("ows_permbot") != 1 then return end
	if #player.GetAll() == 1 then
		perbotcreate()
	end
end)

Code is in the init.lua of the addon, worked fine in singleplayer(hadnt ulx installed there) the functions itself of the snipped worked fine, it only bugged ulx. yes, stuff like settings2.botname etc is created, so its not the cause.

bump >-<

I love how nice the community is ^-^

It’s working fine with my admin mod, and by just calling Kick() on it normally. You should probably ask over at the ULX Forums, considering it’s a ULX problem.

edit:
after putting ULX on my server, it looks like it’s because the NextBot is an “Unauthed Player”

With XGUI



Unauthed player
  1. query - [C]:-1
   2. makePlayerList - addons/ulx/lua/ulx/log.lua:353
    3. unknown - addons/ulx/lua/ulx/log.lua:470
     4. gsub - [C]:-1
      5. fancyLogAdmin - addons/ulx/lua/ulx/log.lua:449
       6. call - addons/ulx/lua/ulx/modules/sh/util.lua:40
        7. __fn - addons/ulib/lua/ulib/shared/commands.lua:943
         8. unknown - addons/ulib/lua/ulib/shared/commands.lua:1296
          9. Run - lua/includes/modules/concommand.lua:54
           10. unknown - addons/ulib/lua/ulib/shared/commands.lua:1310
            11. unknown - lua/includes/modules/concommand.lua:54


Chat Command



addons/ulx/lua/ulx/log.lua:353: [ULIB] Unauthed player


it happens when I try any command on authed players, like, if I want to mute/gag a normal player, nothing happens, but !menu, !rcon and such work fine.