Player spawning outside the map

Hello guys, i would like some help here, please.

I don’t know what exactly caused this, but, everytime i load a map, i spawn on a correct spawn point for a very fast second then get teleported to somewhere outside the skybox.

Also, if i create a server and call other people to join, this thing happens with them too. I guess the problem is really on MY garrysmod.

I don’t know if this was an addon or something. (even thought i tried to remove the last addons i’ve added, and it still happens)

I know i can get out of there using noclip, but’s terrible annoying to do that, specially when i’m playing hl2 maps on multiplayer with my friends, gotta fly the whole thing to find the correct room.

Have this happened with anyone else? Please, help me, i would be very grateful.

<b>EDIT</b>: The problem was solved. Check my last post if you want to see the solution.

Hi,

Try to delete, or move your “steam_user\garrysmod\garrysmod\cache” folder.

If this don’t work, try renaming “steam_user\garrysmod\garrysmod” to any name, to reinstall game.

This looks like a lua script. Check your addons folder to see if you have any addon that might be doing it. You could aslo look in the lua folder.

First, really thanks for replying. Well, when i tried move or rename the cache folder, it said there was a program using it. I tried to kill the proccess of the TortoiseSVNCache, but it still didn’t let me do it. Luckly, i managed to rename the cache folder to another name when i started windows as “Secure Mode”.

Back in normal startup, tried load a hl2 random map and guess what, no, it didn’t work, I’m still spawning outside the map. Do i really need to MOVE it outside the garrysmod folder or just RENAMING would do the trick?

Don’t you have any others ideas what can i do? I wouldn’t like to reinstall all the stuff again… not mentioning that some of the addons aren’t in the addons folder, but merged with the original files… So I can’t just copy and paste…

Thanks again.

Thanks for the reply, man. That’s exactly what i think it’s causing the trouble. But the problem is… i have lots of addons… plus i have tons of “shared” lua files, which all came from others servers… And i’m not a lua coder… (I can understand some structures that were already written, but nothing so deep as a coder would.)

Any other hint? Please? =) Thanks again.

EDIT EDIT EDIT
Forgot to say something. This happens ONLY when i’m on singleplayer, or when i’m hosting a local server. When i join others servers, this never ever happens. (And i don’t remember joining a server which had the same problem as me.)

I’m guessing there is a lua script somewhere running the code “SetPos” on you like 0.5 seconds after you spawned. Since SetPos is server side only, it wouldn’t affect you when you’re in someone else’s server.
Screenshot of your addons folder?
What do you mean by loads of shared lua files that come from other servers?

Now that’s interesting. I actually remember a lua error popping out my screen when i load a map which said something about SetPos. I’m gonna check it and post it here what i found out.

When i say shared lua files… i mean, when you join some servers, it downloads some files before you connect. Most of them are named “shared.lua”.

Sorry if it sounded noobish, but i thought those files were just common lua files like every other.

**EDIT:**Did you ask for a screenshot of my addons folder? If yes, here you go: http://i226.photobucket.com/albums/dd148/sonicpalace4/addon.jpg

This is not the cause or solution (Might be! You never know.) to the problem but you should remove some of your addons… More addons makes your Gmod slooooow. You should also get SVN for the latest PHX, Wire, Stargate, LS, SBMP and some others.

Since you have so many addons, I’m gonna make a list of things to keep (If SVN, delete then get the SVN) instead of things to remove:
For when joining other servers:
Wiremod (SVN)
PHX (SVN)
Stargate (SVN)
SBMP (SVN)
Wire Extras (SVN)
Gcombat ( http://www.garrysmod.org/downloads/?a=view&id=68442 or http://www.garrysmod.org/downloads/?a=view&id=35442 )
Gcombat Xtended (SVN)
Life support & Resource Distribution (SVN)
Smartsnap ( http://www.garrysmod.org/downloads/?a=view&id=35405 )
optional: gb radial (It’s epic - http://www.garrysmod.org/downloads/?a=view&id=55749 )
For when hosting a listen server:
Smart Constraint/Weld ( http://www.garrysmod.org/downloads/?a=view&id=22203 )
Weight Tool ( http://www.garrysmod.org/downloads/?a=view&id=17860 )
Sui scoreboard ( http://www.garrysmod.org/downloads/?a=view&id=66617 )
Anti noclip ( http://www.garrysmod.org/downloads/?a=view&id=29932 )
Deathsounds ( http://www.garrysmod.org/downloads/?a=view&id=53992 )
Simple Prop Protection (SVN)
Stacker Tool ( http://www.garrysmod.org/downloads/?a=view&id=29854 )
optional: LAZOR Tool (BLAAARGH, SVN)
Maybe even one of my addons? (Also SVN)

For those that have (SVN): http://www.facepunch.com/showthread.php?t=688324

FOUND IT! Finally! Only came here again to tell what i did, in case someone else has the same problem as me.

The file was “lua/autorun/Oviscripts.lua” It was something to make NPC controlling on DarkRP, but i never found out how to make it work.

I opened the file on Notepad++, and yeah, there was a “SetPos()” function there, with something about “spawn” as parameter. I removed the file, and there you go. Never had the same problem.

Really thanks for all the help here guys, i’m very grateful. I owe you one.