Playermodels Not Appearing In Shop

So I have been having a problem with some playermodels not appearing in my pointshop menu, even though they work on my DarkRP server and when I try to make them on my TTT server, they never work.

Heres one that doesnt work:
[lua]
ITEM.Name = ‘(VIP Custom) Gold’
ITEM.Price = 0
ITEM.Model = ‘models/player/daftpunk/daft_gold.mdl’
ITEM.AllowedUserGroups = { “superadmin” }
ITEM.SubCategory = “Playermodels”

function ITEM:OnEquip(ply, modifications)
if not ply._OldModel then
ply._OldModel = ply:GetModel()
end

timer.Simple(1, function() ply:SetModel(self.Model) end)

end

function ITEM:OnHolster(ply)
if ply._OldModel then
ply:SetModel(ply._OldModel)
end
end

function ITEM:PlayerSetModel(ply)
ply:SetModel(self.Model)
end
[/lua]

And here is one that does work:
[lua]
ITEM.Name = ‘(VIP Custom) Gandolf’
ITEM.Price = 0
ITEM.Model = ‘models/koz/lotr/gandalf/gandalf.mdl’
ITEM.AllowedUserGroups = { “superadmin”}
ITEM.SubCategory = “Playermodels”

function ITEM:OnEquip(ply, modifications)
if not ply._OldModel then
ply._OldModel = ply:GetModel()
end

timer.Simple(1, function() ply:SetModel(self.Model) end)

end

function ITEM:OnHolster(ply)
if ply._OldModel then
ply:SetModel(ply._OldModel)
end
end

function ITEM:PlayerSetModel(ply)
ply:SetModel(self.Model)
end
[/lua]

Does anyone have any ideas what is going on with these models?

What is the name of the folder these models are located in?

[editline]11th September 2014[/editline]

Also, what’s the name of their lua files?

I put them both in Addons.
One was just called Daft Punk and the other was just called Gandolf.
I took the paths from the autorun folder.

Its point shop I had this same problem the model will show put for most of them but some its just blank

Wild guess but try and male the lua filename without gaps i.e “blabla.lua” instead of “bla bla.lua”
Also make sure no other model has the same model name and file name even if in different categories.
Also make sure the pointshop category folders don’t have caps/spaces and make sure the model folders are lowercase (the actual model, not talking about the text in the lua file).

[editline]12th September 2014[/editline]

Oh also make sure you are superadmin on the ttt server!

You can’t just put it in autorun, put it in the specific Pointshop folder. Also, don’t put spaces in folder/lua file names.

Its in addons/<modelname>/lua/autorun/<whateverthemodellercalledit>.lua

I know how to do it, I just dont know why its not working for some models when they work on my DarkRP server.

Put it in ~ / lua / pointshop / items / (category) / something.lua

I mean to say that the items are all there and accounted for in the items, but the pathway isnt working like I found it in the previously displayed path.

What EXACTLY is your issue?

Some of them dont appear in my TTT pointshop! They work in other gamemodes but when I try to put them in the pointshop, they just dont appear!

[editline]13th September 2014[/editline]

Thanks for the dumb ratings people when you also have no idea what is going on people…

is your item in following path (JUST the Lua file of your item)
garrysmod\addons\pointshop-master\lua\pointshop\items\playermodels\gandalf.lua
and does not contain spaces? pointshop-master could also be pointshop.
this is just for the code you posted, not for some lua files that are bundled with your skins.

Did you modified the pointshop itself? Like with an custom skin or simmilar?
Are you using _undefiends Pointshop, not something like Pointshop 2 of Kamshack?

edit:// 100 post :slight_smile:

Just a reskined version, but no core files are modified. Some models work and some dont.