Please help me with my srcds gmod server

Hi there.

i just found out how to get a dedicated server with hlds update tool. i have done all that it says and i have the server and stuff. i run it, i can join it but know one else can. for me it shows up as a LAN server and my friends cant find it on the list of internet servers. i have tryed typing sv_lan 0 but still didn’t work. sometimes when my friend trys to join it says failed to join after 4 retries or soming. but sometimes it will let him join and it gets to sending client info and the thing in middle spins around for ages. we waited 20mins and still nothing, it just spins and does nothing. What do i do/what have i done wrong. i have forwarded ports. 27015 both tcp and upd and also 27020 upd. are they right.

i also found out that when it sometimes lets him join it says on the server console that he has joined and then it says “hissteamname”-conected but his screen is still on the sending client info and thing is spining.

please help me im not all that good with pcs my knolage is not very good. can someone give me step by step instructions on what to do.

thanks in advance. =]

Check your router configuration is correct for your internal IP address.

what do you mean. i have a bt-homehub 2 router. wheres that option???

I’m curious about this as well. I’m having a similar issue.

Listen. i dont need to port forward because i allready have done it. all i need to know is have i forwarded the right ports and why it isn’t working. ow and i have a BT-HomeHub2.0 router.

27015 UDP/TCP

Did you setup an internal static IP?

OK I’m having the same problem. I’ve set up a srcds dedicated and besides the fact that it isn’t connected to the internet it’s working fine.

The problem is that it refuses to turn itself into an internet server, instead of a LAN one. I’ve already port forwarded to port 27015 UDP/TCP.

However, there’s only one thing strange about my internet, the IP address. For some reason, my IP address is 10.0.0.1, and it’s always been 10.0.0.1 and refuses to change even though it’s dynamic. So using the port forwarding site I decided to make my Static IP 10.0.0.2, because it was the only IP I could get to work.

I have 2 routers (which I think is the problem). One is a verizon fios Actiontec MI424-WR which takes in my internet via cable and then turns it over to my other wireless router, a Netgear WPN824 v2.

I’m stumped on this concept alone. www.portforward.com says that the IP for my netgear router is 192.168.1.1, however when I type that in I get sent to the login site for my actiontec router. 10.0.0.1 sends me to the login site for my netgear router.

Any help would be great.

your IP is not 10.0.0.1

edit - also yes, using 2 routers and expecting no conflicts is…unthinkable

One way to find your connect xxx ip address, is to host a server, then type status.
The last 5 numbers are the port. Foward that.

I ended up disconnecting my netgear router and just connecting my actiontec straight to my computer. I followed the guide on www.portforward.com again and tried to set up a static IP again. Of course, it didn’t work.

New info:
With a DYNAMIC IP address I get (using the command prompt and ipconfig /all)
IP address- 192.168.1.2
Subnet Mask- 255.255.255.0
Default Gateway- 192.168.1.1
DNS Servers- 192.168.1.1

Another thing I found that hints what might be up, www.portforward.com says that if the IP is the same as the DNS then it means that the router acts as a proxy between the real DNS servers. Apparently I don’t have the right DNS server(s). I looked it up but I can’t seem to find it.

Also… the guide specifically says to use an IP which is close to your router’s IP, but it shows how to get the IP from ipconfig, which I’m almost certain is the computer’s IP, or at least the router’s internal IP. I’m also guessing that by using these “internal” IP’s I’m somehow connecting the server strictly to LAN. But I don’t know.

I’ll try my external IP address- 74.96.175.104

Hold on a min can we please stay on task. i need help on my server, it still wont let people join and it still is showing on the LAN list although i have forwarded the ports. my frined still cant see it on the internet list. can someone please help.

[editline]03:52PM[/editline]

im sorry my knolage with computers isn’t very good. what do you mean internal static ip???

[editline]03:52PM[/editline]

im sorry my knolage with computers isn’t very good. what do you mean internal static ip??? can you try to give me a step by step instructions on how to do this. my router is a BT-HomeHub 2.0.

Do you have the server.cfg file in your cfg folder? If not make it. That would be the problem.
How to make it? Here:

  1. Go into: C:[your server folder]\orangebox\garrysmod\cfg

  2. Make a notpad and put these things:
    hostname [your server name]
    sv_lan 0

  3. Save it as… and type the name ‘‘server.cfg’’, press OK

  4. You done. Now try it.

If the problem is not fixed go: www.whatsmyip.org, copy it and from the steam add the ID: [your id that you copied]:27015 to your favorites

NOTE: Remember to restart your server

I managed to get mine to work.

Did you properly port forward ports 27005-27015 (one for both TCP and UCP)? If not, do that. Then make sure to allow your firewall to let in ports 27005 and 27015 (make an exception for both of these ports and both TCP and UCP, you should be making 4 port exceptions).

That fixed my problem, might work for you.

no i didn’t have the server.cfg file. i made it and put the stuff in it but it made no difference. any other sugestions??

[editline]09:10PM[/editline]

well i have forwarded those ports and allowed them on my rule list on my firewall but it has made no difference. still shows in the LAN list for me. i cant see it on internet list. when i give the address to my friends it wont let them join. (server is not responding). the thing i dont understand is it sometimes lets my friend join and it says on my server consol that he is in the game. but for him his screen is stuck on the “sending client info” screen with the thing in middle just spinning. we waited for ages but it just stays on that screen. please help me someone. i dont understand what im doing wrong.

Try putting the code
IP <IP address>

above your “hostname” code in your server.cfg file.

nope still didn’t work. still showing in the LAN list and notin the internet list.

how hard can it be to make a bloody server. this is just getting stupid now.

any other sugestions. could you tell me how you got your server. where you downloaded it from and exactly what you did to get it working so i can follow what you have done. thanks in advance.

You might also double check your Static IP address.

Lets say you set you were setting up your static ip and you found that your current IP was 192.168.1.2. So you changed your static IP to 192.168.1.2… or something.

Well the problem is that your DNS (domain name server) automatically assigns IPs to every device on your computer. And sometimes it might assign a different device to 192.168.1.2, meaning that the internet on your computer wouldn’t work.

So you can try changing the last number to something like 135, where you DNS would never get to. So instead of 192.168.1.2, you would get 192.168.1.135. The rule is you can change the last number as much as you want and your IP and internet will still work.

Then again, if this was the problem, your internet wouldn’t be working. And because it is, it probably isn’t the problem. But it is worth a try.

Its still not working. im still having the same problems as i did at the very start. can anyone help. PLEASE I REALLY WANT A GMOD DEDICATED SERVER!!!

or is there any other way of getting a gmod dedicated server without paying.