PLEASE HELP MY SERVER BROKE! bad argument #1 to 'string_len' (string expected, got boolean)

Hello, I’ve recently run into a problem with my server and I don’t know what to do. the error i get exactly is:

[ULib] lua/includes/extensions/string.lua:89: bad argument #1 to ‘string_len’ (string expected, got boolean)

  1. string_len - [C]:-1
  2. Split - lua/includes/extensions/string.lua:89
    3. fn - addons/prometheus/lua/prometheus/weapons.lua:40
    4. Call - lua/ulib/shared/hook.lua:110
    5. unknown - gamemodes/starwarsrp/gamemode/modules/base/sv_gamemode_functions.lua:719
    6. Spawn - [C]:-1
    7. unknown - gamemodes/base/gamemode/player.lua:115

Contact whoever made the addon.

Pretty simple, whenever you use string.Explode use the correct arguments, because seems like you used a boolean more than string

Just kidding, you have no idea what’s going on there, remove prometheus in case you don’t really own it, and remove the extra addons you’ve added into it, because one fucked it, but no one will give you a real solution here because we don’t have idea about your error as it

One of your problems (most likely) are

  1. fn - addons/prometheus/lua/prometheus/weapons.lua:40
    and/or
  2. unknown - gamemodes/starwarsrp/gamemode/modules/base/sv_gamemode_functions.lua:719
    I would double check your code. If you haven’t touched anything, but added in addons before it broke. Check the addons that you installed. remove them and add them one by one.