PLEASE HELP!

Just wondering if anyone is having the same issue as me and if there is a fix.

When ever I play on servers I can play normally. However this only lasts for a while at which point I can no longer gather resources. What seems to happen is that I lose connection with the server somehow. Although this seems to be the case, I can still see other players move around me, I can still see global chat, I can still place building components which other players can also see being placed. The weird thing is that to every other player, my character is standing still in the same position. However, to me, I am still moving around, I am just unable to interract with anything such as boxes, dead animals etc, and i lose no ammo from my torch if I am using it. I can still see other players, all of which cannot see me, even if from my end it says I am standing directly in front of them. If I hit them with a rock they take no damage, and receive no indication they are being hit.
My housemates both play and have no such issues. I also have this issue on every server I play. The only fix I have found so far is to disconnect from the server and reconnect which seems to fix the problem, until at some stage, without any obvious trigger or notification, I seem to lose partial connection to the server.

Any help would be appreciated, I am sick of disconnecting and reconnecting every 5 minutes and also watching zombies hit the air and kill me while I watch from 50 meters away.

Thanks


(User was banned for this post ("undescriptive all caps thread title, make one thread not two" - postal))