ply:DrawWorldModel(false)

Well I am doing something where I need to not draw the worldmodel of the weapon, and DrawWorldModel false works, but when I switch weapons it resets. Any way I can fix?

All I’ve tried so far is this and it doesn’t work.
[lua]
hook.Add(“Deploy”,“weaponchangecloak”,function(ply,key)
ply:DrawViewModel(false)
ply:DrawWorldModel(false)
end) [/lua]

Try adding it to the deploy function, inside the SWeps code.

I would do that but the suck part is if I want it to function correctly it needs to be able to do it for all weapons…

No idea if this would work, but you could try setting it “true”, when it gets holstered?

[editline]02:10AM[/editline]

Like, hook it up.

…I just looked at the Wiki on it…

Fuck.
And when it gets holstered it resets it anyways, otherwise when I pull back out the first weapon it would be drawworldmodel false.

[editline]12:15AM[/editline]

[del]Maybe I could try and get a table of all the player’s weapons then check if its one of those then set Drawworld to false if current weapon is one of them and hook it all to think.[/del]

[editline]12:20AM[/editline]

[del]Or I could just hook ply:DrawViewModel(false) and ply:DrawWorldModel(false) to think instead of doing it the hard way…[/del]

[editline]12:27AM[/editline]

Scratch that it doesn’t work…STILL