Point_clientcommand

So I am making a basic server joining map. You walk into one and it takes you to a set server. I am having problems with point_clientcommand. What I did was make a point_clientcommand in every server join room. Then I went to outputs and added fire onuser 1, entitie: rp, command connect serveripwashere.

Didn’t work. Ehh I’ve been mapping for a year now, but I have never used any “Point” anything. Any bit of help would benefit me.

Thanks so much you guys,

Props.

Isn’t it just point_consolecommand, and you need to do “connect IP”.

I tried to do the whole “Command Connect Iphere” situation and as I tested the level. I tried in Gmod (Gmod is the game I am using it on) and it looked in hammer to be fine. I launched it up in Multiplayer and walked into the room with a point_clientcommand. Nothing happened.

[editline]05:58PM[/editline]

Hmm No help?

Use a trigger_multiple OnTrigger to give the point_clientcommand the parameter to execute.

sry to bring up that old post again!

could it be that gmod blocks point_clientcommand ?

i made a map with 2 rooms just right above each other, there s a trigger_once on one side of the lower room (same room as the spawn). this trigger calls the point_clientcommand executing a concommand of a lua file i have in /autostart/server/

luafile:


local trigger_up = Vector(0, 0, 768)
 
 
function move_to_top(player, commands, args)
    if player:IsAdmin() or player:IsSuperAdmin() then
            player:SetPos(player:GetPos() + trigger_up)
        end
end
            
concommand.Add("move_to_top", move_to_top)

the code DOES work, if im ingame and type “move_to_top” in console i get portet to the top room!
but it somehow doesnt work, to trigger the concommand with the trigger_once and point_clientcommand!

thanks in advance
numu

Its blocked in gmod.

ok, then, you maybe got an idea how i could teleport, but not with teleport_destination, i need it to ignore the X and Y coordinates only take the Z coords i tell it to use ?

[editline]11th August 2012[/editline]

ok forget about that teleportthing, its important, but im sure ill need to trigger lua scripts anyway in different situations as well.

so ? is there ANY way to get into the luastructure from hammer ?
this is really important to me, so id be very happy with every answer and hint i get!

cheers
numu