PointShop 2 ERROR Lua

I received this error when trying to install the PointShop 2 on my server.

I did exactly everything it said the page, but I still have this error.

Like someone has happened the same and found the solution?

CLIENT:


[ERROR] lua/vgui/dpropertysheet.lua:51: attempt to index a nil value
  1. IsActive - lua/vgui/dpropertysheet.lua:51
   2. unknown - addons/pointshop2/lua/ps2/client/cl_dermaskin_flatui.lua:310

SERVER:


[TuXEKRO|20|STEAM_0:1:75458190] Lua Error:

[ERROR] addons/pointshop2/lua/ps2/client/cl_dpointshopmenuedtab.lua:30: attempt to index a nil value
1. ApplySchemeSettings - addons/pointshop2/lua/ps2/client/cl_dpointshopmenuedtab.lua:30
2. SetFont - lua/vgui/dlabel.lua:55
3. Init - addons/pointshop2/lua/ps2/client/cl_dpointshopmenuedtab.lua:6
4. Create - lua/includes/extensions/client/panel/scriptedpanels.lua:153
5. Add - lua/includes/extensions/client/panel.lua:474
6. addMenuEntry - addons/pointshop2/lua/ps2/client/cl_dpointshopmenuedtab.lua:141
7. Init - addons/pointshop2/lua/ps2/client/tabs/inventory_tab/cl_0_dpointshopinventorytab.lua:16
8. Create - lua/includes/extensions/client/panel/scriptedpanels.lua:153
9. Init - addons/pointshop2/lua/ps2/client/cl_dpointshopframe.lua:110
10. Create - lua/includes/extensions/client/panel/scriptedpanels.lua:153
11. OpenMenu - addons/pointshop2/lua/ps2/client/cl_0_pointshop2.lua:6
12. ToggleMenu - addons/pointshop2/lua/ps2/cl[TuXEKRO|20|STEAM_0:1:75458190] Lua Error:

[ERROR] addons/pointshop2/lua/ps2/client/cl_dpointshopmenuedtab.lua:30: attempt to index a nil value
1. unknown - addons/pointshop2/lua/ps2/client/cl_dpointshopmenuedtab.lua:30


[TuXEKRO|20|STEAM_0:1:75458190] Lua Error:

[ERROR] addons/pointshop2/lua/ps2/client/cl_dpointshopmenuedtab.lua:30: attempt to index a nil value
1. unknown - addons/pointshop2/lua/ps2/client/cl_dpointshopmenuedtab.lua:30


[TuXEKRO|20|STEAM_0:1:75458190] Lua Error:

[ERROR] addons/pointshop2/lua/ps2/client/cl_dpointshopmenuedtab.lua:30: attempt to index a nil value
1. ApplySchemeSettings - addons/pointshop2/lua/ps2/client/cl_dpointshopmenuedtab.lua:30
2. unknown - addons/pointshop2/lua/ps2/client/cl_dpointshopmenuedtab.lua:12


[TuXEKRO|20|STEAM_0:1:75458190] Lua Error:

[ERROR] lua/vgui/dpropertysheet.lua:51: attempt to index a nil value
1. IsActive - lua/vgui/dpropertysheet.lua:51
2. unknown - addons/pointshop2/lua/ps2/client/cl_dermaskin_flatui.lua:310

Ask the author on Scriptfodder.

By any chance is PAC3 installed? If not, install it.

Talk to Kamshak, the creator of that script. Also make sure you have LibK and Pac3 installed.

Yes, I installed LibK and PAC3 in the addons folder.

A put other folders:

  • Addons / libk / resource
  • Addons / pointshop2 / materials

In FastDL.

If you bought it ask Kamshak for support. Otherwise, too bad.

This is an error caused by a recent gmod update, you are using an outdated version of PS2. I assume it’s leaked since you have not purchased the script on scriptfodder. If an admin/dev/friend of yours purchased the script please send me their name as a PM.