Pointshop 2 lua error

i get this error when trying to open pointshop 2 on a server i played before.
[ERROR] lua/includes/extensions/net.lua:182: net.ReadType: Couldn’t read type 31

  1. error - [C]:-1
  2. ReadType - lua/includes/extensions/net.lua:182
    3. ReadType - lua/includes/extensions/net.lua:121
    4. ReadType - lua/includes/extensions/net.lua:124
    5. ReadType - lua/includes/extensions/net.lua:124
    6. ReadType - lua/includes/extensions/net.lua:124
    7. ReadTable - lua/includes/extensions/net.lua:124
    8. func - addons/libk/lua/libk/client/cl_libk_baseview.lua:65
    9. unknown - lua/includes/extensions/net.lua:32

GLib.Loader : Running pack file “GLib”, deserialization took 174.21 ms (229 total files, 807.08 KiB).
GLib.Loader : Running pack file “GLibAddons”, deserialization took 13.06 µs (0 total files, 16.00 B).

I didnt have this issue until i got banned and then came back. I tried a fresh install of gmod still no luck.

Tell the server owner/developers.

i have the dev said he didnt know what was causing the issue . I honestly dont think he knows too much about lua

It’s a paid addon, open a support ticket with the seller on ScriptFodder

not the owner of the serer or i would . already asked the owner to make a support ticket he said he will but has yet to do it . Im the only one on the server with the issue it only happened after i came back from a 2 week ban