Poor server performance

Hey,
I set up a garrysmod server with pretty good specs:
i7-3770 16gb ram
100mbit connection

The problem that I have is that when there are more than 25 players on it,
the frame rate goes crazy and if there are more than 28 online it drops to 2 fps and unplayable lags.
I already checked the code of the gamemode twice (every think, timer and hooks) but I couldn’t find anything that would
cause that much lag. The inet connection isn’t the issue either, I have an average of 0.2mb/s up and download.
Is this a general garrysmod issue or is it because one core of the i7 does not have enough performance for more than 28players?
Could it be related to hyperthreading that basically only half a core is used?

Thank you really much
syl0r

that’s odd did you try contacting your host?

Post your server.cfg file here your rates may have something to do with it, I’m sure you’ve already got those setup properly

Don’t forget to remove the rcon password before you post it, if you do.

Definitely make a ticket with your host as well

I haven’t set up any rates in the config yet, are rates really reducing the server performance (fps) ?
It wouldn’t make sense to contact the host because it is a root server and the cpu is set up correctly and is going up to 3.4ghz per core when more players are online.

server cfg:
hostname “XXXXXXX”
sv_password “”
gamemode “XXXX”
sv_kickerrornum 0
sv_stats “1”
rcon_password “XXXXXXX”
sv_downloadurl “XXXXXXXXXXX”
sv_allowupload “0”
sv_allowdownload “0”
sv_loadingurl “XXXXXXXXXXX”
sv_timeout 600

so as you can see, nothing special.

What is your tickrate? If it’s 66 try lowering it to 33tick… This helped my server immensely when the server goes over 30 players.

I will try that as soon as I can, thanks.

[editline]14th July 2013[/editline]

I don’t think that worked, it is more stable than before but the fps is still dropping to 10fps on the server.
Is an i7-3770 core just not good enough or is it a fault on my end (gamemode), then I will check it for the third time.

you have set host_framerate 1000 and fps_max 1000 aswell as opened windows media player to get around the kernel timer being limited on windows? There is also a startup launch option to control fps_max you need that aswell.

Here is a piece of my server.cfg all hell bent towards utmost performance


host_thread_mode 2
host_framerate 1000
fps_max 1000
sv_allow_color_correction 0
sv_alternateticks 1
sv_forcepreload 1
cl_forcepreload 1
g_ragdoll_maxcount 0
r_decals 0
mp_decals 0
mp_footsteps 0
sv_maxupdaterate 33
sv_minupdaterate 20
sv_maxcmdrate 33
sv_mincmdrate 20
sv_maxrate 0
sv_minrate 12500
sv_allowdownload 1
sv_allowupload 0

And most of my launch options:


-console -nocrashdialog -game garrysmod +ip 50.31.65.186 -port 27015 +maxplayers 64 +map dx_rp_occupation_5a +exec server.cfg +gamemode dayx -tickrate 33 -pingboost 3 -nohltv 

Thanks for that but I should’ve mentioned that I am using linux so the windows kernel timer isn’t a problem.
I have set up most of the stuff to what you have in your config, still doesn’t give me more (stable) fps :frowning: