Port Forwarding Does Not Work

I’m having trouble forwarding my ports for Gmod.
First off, I have both a WRTG54 Lynksis router, AND an Actiontec M1000 Qwest router.

I have tried forwarding port 27015 with both TPC and UPD on the Lynksis router, but the Qwest router is funny, because it won’t allow me to use my Local IP, 192.168.1.102, but it will use 192.168.0.1, and I am not getting any signs that it is working. I’ve added the ports to my firewall, so it is not blocked. Gmod is not blocked, nor is Steam.
Everything I try still get’s the no-go from this website: http://canyouseeme.org/
What am I doing wrong, and how do I do it right?

The main problem is that I can port forward one router, because I have a 192.168.1 IP, but the other router won’t forward a port unless it is a 192.168.0 IP. How do I get it to work?

problem solved

I am actually not sure they are or not. I believe that one receive the internet, and one allows it, because the provider is Qwest. In fact, they have an Ethernet cable connecting the two.