Portal, custom map error

EDIT: Started on a new map, problem “solved” :stuck_out_tongue:
Thank you to everyone who took their time to help me.

Portal doesn’t use the hev suit, try removing that

Um, yes. The H.E.V suit is built into the Source engine pretty much. It does work in Portal. You can get it yourself by just typing impulse 101 in the console while playing a standard Portal map, gives you the HEV suit (HUD) along with all weapons.

I’m saying the map worked fine the first time I launched it, and it had the H.E.V suit back then, along with the crowbar.

Both of them work perfectly fine.

EDIT: Either way I did try removing the H.E.V suit but I still had the error.

Anyone else got anything on this?

(Sorry for double post.)

don’t know then, sorry :confused:

tried making a new easy map just to see if it isn’t hammer problem, etc

Yes I tried that, new maps work fine without a problem, however I just had the exact same error while doing a map in Episode 2. Turns out the error is random shit really. One time I compile, it doesn’t work. I recompile, it works…

that’s odd

Item suit works fine. You can also rig it to use chell’s hands.

Post the compile log.

do you have any FUNC_area_portals?

they screwed me over when i accidently made the ground one.

Not really, as I have no idea what those would do, I’m not a very experienced with hammer :stuck_out_tongue:



** Executing...
** Command: "d:\games\steam\steamapps\deviouz666\sourcesdk\bin\orangebox\bin\vbsp.exe"
** Parameters: -game "d:\games\steam\steamapps\deviouz666\half-life 2 episode two\ep2" "D:\Games\Steam\steamapps\deviouz666\portal\portal\maps\ep3_arctic01"

Valve Software - vbsp.exe (May 19 2009)
8 threads
materialPath: d:\games\steam\steamapps\deviouz666\half-life 2 episode two\ep2\materials
Loading D:\Games\Steam\steamapps\deviouz666\portal\portal\maps\ep3_arctic01.vmf
material "concrete/concrete_modular_wall001f" not found.
Material not found!: CONCRETE/CONCRETE_MODULAR_WALL001F
material "concrete/concrete_modular_floor001c" not found.
Material not found!: CONCRETE/CONCRETE_MODULAR_FLOOR001C
material "concrete/concrete_bts_sumpfloor" not found.
Material not found!: CONCRETE/CONCRETE_BTS_SUMPFLOOR
fixing up env_cubemap materials on brush sides...
ProcessBlock_Thread: 0...1...2...3...4...5...6...7...8...9...10 (0)
ProcessBlock_Thread: 0...1...2...3...4...5...6...7...8...9...10 (0)
Processing areas...done (0)
Building Faces...done (0)
Chop Details...done (0)
Find Visible Detail Sides...done (0)
Merging details...done (0)
FixTjuncs...
PruneNodes...
WriteBSP...
done (0)
writing D:\Games\Steam\steamapps\deviouz666\portal\portal\maps\ep3_arctic01.prt...Building visibility clusters...
done (0)
Creating default LDR cubemaps for env_cubemap using skybox materials:
   skybox/sky_day01_01*.vmt
 ! Run buildcubemaps in the engine to get the correct cube maps.
Creating default HDR cubemaps for env_cubemap using skybox materials:
   skybox/sky_day01_01*.vmt
 ! Run buildcubemaps in the engine to get the correct cube maps.
Finding displacement neighbors...
Finding lightmap sample positions...
Displacement Alpha : 0...1...2...3...4...5...6...7...8...9...10
Building Physics collision data...
done (0) (44370 bytes)
Error loading studio model "models/props/door_01_frame_wide_reference.mdl"!
Error! To use model "models/combine_helicopter.mdl"
      with prop_static, it must be compiled with $staticprop!
Error loading studio model "models/combine_helicopter.mdl"!
Placing detail props : 0...1...2...3...4...5...6...7...8...9...10
Compacting texture/material tables...
Reduced 308 texinfos to 153
Reduced 17 texdatas to 16 (443 bytes to 391)
Writing D:\Games\Steam\steamapps\deviouz666\portal\portal\maps\ep3_arctic01.bsp
1 second elapsed

** Executing...
** Command: "d:\games\steam\steamapps\deviouz666\sourcesdk\bin\orangebox\bin\vvis.exe"
** Parameters: -game "d:\games\steam\steamapps\deviouz666\half-life 2 episode two\ep2" -fast "D:\Games\Steam\steamapps\deviouz666\portal\portal\maps\ep3_arctic01"

Valve Software - vvis.exe (May 19 2009)
fastvis = true
8 threads
reading d:\games\steam\steamapps\deviouz666\portal\portal\maps\ep3_arctic01.bsp
reading d:\games\steam\steamapps\deviouz666\portal\portal\maps\ep3_arctic01.prt
 134 portalclusters
 354 numportals
BasePortalVis:       0...1...2...3...4...5...6...7...8...9...10 (0)
Optimized: 427 visible clusters (0.00%)
Total clusters visible: 11883
Average clusters visible: 88
Building PAS...
Average clusters audible: 133
visdatasize:5602  compressed from 6432
writing d:\games\steam\steamapps\deviouz666\portal\portal\maps\ep3_arctic01.bsp
0 seconds elapsed

** Executing...
** Command: "d:\games\steam\steamapps\deviouz666\sourcesdk\bin\orangebox\bin\vrad.exe"
** Parameters:  -game "d:\games\steam\steamapps\deviouz666\half-life 2 episode two\ep2" -noextra "D:\Games\Steam\steamapps\deviouz666\portal\portal\maps\ep3_arctic01"

Valve Software - vrad.exe SSE (May 19 2009)

      Valve Radiosity Simulator     
8 threads
[Reading texlights from 'lights.rad']
[48 texlights parsed from 'lights.rad']

Loading d:\games\steam\steamapps\deviouz666\portal\portal\maps\ep3_arctic01.bsp
Setting up ray-trace acceleration structure... Done (0.14 seconds)
740 faces
2 degenerate faces
18258 square feet [2629280.75 square inches]
1 Displacements
2871 Square Feet [413479.69 Square Inches]
738 patches before subdivision
1780 patches after subdivision
7 direct lights
BuildFacelights:     0...1...2...3...4...5...6...7...8...9...10 (0)
BuildVisLeafs:       0...1...2...3...4...5...6...7...8...9...10 (2)
transfers 108013, max 243
transfer lists:   0.8 megs
GatherLight:         0...1...2...3...4...5...6...7...8...9...10 (0)
	Bounce #1 added RGB(8718, 8341, 7045)
GatherLight:         0...1...2...3...4...5...6...7...8...9...10 (1)
	Bounce #2 added RGB(460, 446, 314)
GatherLight:         0...1...2...3...4...5...6...7...8...9...10 (1)
	Bounce #3 added RGB(55, 56, 33)
GatherLight:         0...1...2...3...4...5...6...7...8...9...10 (1)
	Bounce #4 added RGB(9, 10, 6)
GatherLight:         0...1...2...3...4...5...6...7...8...9...10 (1)
	Bounce #5 added RGB(2, 2, 1)
GatherLight:         0...1...2...3...4...5...6...7...8...9...10 (1)
	Bounce #6 added RGB(0, 0, 0)
Build Patch/Sample Hash Table(s).....Done<0.0005 sec>
FinalLightFace:      0...1...2...3...4...5...6...7...8...9...10 (1)
FinalLightFace Done
0 of 0 (0% of) surface lights went in leaf ambient cubes.
ThreadComputeLeafAmbient: 0...1...2...3...4...5...6...7...8...9...10 (1)
Writing leaf ambient...done
Ready to Finish

Object names       Objects/Maxobjs  Memory / Maxmem  Fullness 
------------       ---------------  ---------------  -------- 
models                   4/1024          192/49152    ( 0.4%) 
brushes                143/8192         1716/98304    ( 1.7%) 
brushsides            1201/65536        9608/524288   ( 1.8%) 
planes                1590/65536       31800/1310720  ( 2.4%) 
vertexes              1147/65536       13764/786432   ( 1.8%) 
nodes                  545/65536       17440/2097152  ( 0.8%) 
texinfos               153/12288       11016/884736   ( 1.2%) 
texdata                 16/2048          512/65536    ( 0.8%) 
dispinfos                1/0             176/0        ( 0.0%) 
disp_verts              81/0            1620/0        ( 0.0%) 
disp_tris              128/0             256/0        ( 0.0%) 
disp_lmsamples        7000/0            7000/0        ( 0.0%) 
faces                  740/65536       41440/3670016  ( 1.1%) 
hdr faces                0/65536           0/3670016  ( 0.0%) 
origfaces              348/65536       19488/3670016  ( 0.5%) 
leaves                 550/65536       17600/2097152  ( 0.8%) 
leaffaces              848/65536        1696/131072   ( 1.3%) 
leafbrushes            440/65536         880/131072   ( 0.7%) 
areas                    2/256            16/2048     ( 0.8%) 
surfedges             4937/512000      19748/2048000  ( 1.0%) 
edges                 2703/256000      10812/1024000  ( 1.1%) 
LDR worldlights          7/8192          616/720896   ( 0.1%) 
HDR worldlights          0/8192            0/720896   ( 0.0%) 
leafwaterdata            0/32768           0/393216   ( 0.0%) 
waterstrips             31/32768         310/327680   ( 0.1%) 
waterverts               0/65536           0/786432   ( 0.0%) 
waterindices           534/65536        1068/131072   ( 0.8%) 
cubemapsamples           0/1024            0/16384    ( 0.0%) 
overlays                 0/512             0/180224   ( 0.0%) 
LDR lightdata         [variable]       56948/0        ( 0.0%) 
HDR lightdata         [variable]           0/0        ( 0.0%) 
visdata               [variable]        5602/16777216 ( 0.0%) 
entdata               [variable]        5321/393216   ( 1.4%) 
LDR ambient table      550/65536        2200/262144   ( 0.8%) 
HDR ambient table      550/65536        2200/262144   ( 0.8%) 
LDR leaf ambient       580/65536       16240/1835008  ( 0.9%) 
HDR leaf ambient       550/65536       15400/1835008  ( 0.8%) 
occluders                0/0               0/0        ( 0.0%) 
occluder polygons        0/0               0/0        ( 0.0%) 
occluder vert ind        0/0               0/0        ( 0.0%) 
detail props          [variable]           1/12       ( 8.3%) 
static props          [variable]           1/694      ( 0.1%) 
pakfile               [variable]      211611/0        ( 0.0%) 
physics               [variable]       44370/4194304  ( 1.1%) 
physics terrain       [variable]         293/1048576  ( 0.0%) 

Level flags = 0

Total triangle count: 2035
Writing d:\games\steam\steamapps\deviouz666\portal\portal\maps\ep3_arctic01.bsp
9 seconds elapsed

** Executing...
** Command: Copy File
** Parameters: "D:\Games\Steam\steamapps\deviouz666\portal\portal\maps\ep3_arctic01.bsp" "d:\games\steam\steamapps\deviouz666\half-life 2 episode two\ep2\maps\ep3_arctic01.bsp"



  • Iam aware of the helicopter and the door frame model, but they worked fine the first time I launched the map so I highly doubt they are the cause.

hmmm, check log try compiling it in default, and just incase for testing reasons remove or replace the failing models

Okay I removed the models and compiled the map with the “Normal” setting on BSP, VIS and RAD, still had the error message hit me in the face.

I tmight be a beeing corrupt error, that your processor makes a calculation mistake wich corrupts your map, there you go with your randomniss :stuck_out_tongue:

You boosted your pc lately? Or it might be too hot in it :ninja:

Uh, I have no idea to be honest. Might be that I’m using Windows XP Home Edition instead of Professional. Had to reinstall it a while ago due to viruses, and I didn’t have my XP Professional CD available at the moment so I had to use Home Edition. I guess I’ll reinstall it again using the Professional CD then :stuck_out_tongue:

I’m not sure if its too hot for it though, it shouldn’t be. If its overheating its meant to be beeping loudly endlessly but that hasn’t happened in ages.