PortForward problem?

Hi, i created a Gmod server yesterday, my friend and his friend from Australia can join and i see my server in the Gmod list but, they use the console to connect to my server.I think i’m the only one to see my server in the list.when i try to add my server on gametracker i receive an error and also, when i try to use Assmod i receive : unable to connect to remote server.My router is a D-Link WBR-2310 here is some pictures of my ports,server : http://img21.imageshack.us/img21/2654/serverjx.jpg | http://img11.imageshack.us/img11/9062/server2p.jpg | http://www.image-upload.ch/upload/September2009/server3.jpg | http://www.image-upload.ch/upload/September2009/server4.jpg . I hope you can help me, i’m always having trouble with those things.

I just tried to do this yesterday, and I got the same error.

[editline]04:33PM[/editline]

Hmm… I just added my server to GameTracker and it worked fine.

Up

-snip-

Do an ipconfig on the server and post a screenshot of that. The IP you pasted in there might not be right. 192.168.0.100 sounds like a modem IP to me.

192.168.0.100 is my router IP , 192.168.0.56 is the default gateway and 74.58.135.145 is my modem IP

What’s the IP of the server? You’re trying to open ports for the router, not the server. That’s your problem.

This is my code in the SRCDS : -console -game garrysmod +map RP_DownTown_v2 +maxplayers 24 -autoupdate +ip 192.168.0.100 -port 27015 So, the ip is 192.168.0.100 but when i want to connect to my server i’m using my modem IP (74.58.135.145) with the port 27015

Do this:

Start > Run
type: ipconfig

Take a screenshot and paste a link to the image. You’re doing it all wrong.

Carte Ethernet Connexion au réseau local :

Suffixe DNS propre à la connexion. . . :
Adresse IPv6 de liaison locale. . : fe80::291a:723d:19d1:cc5d%10
Adresse IPv4. . . . . . . . . . . : 192.168.0.100
Masque de sous-réseau. . . .. . . . . : 255.255.255.0
Passerelle par défaut. . . .
. . . . . : 192.168.0.56

Carte Tunnel Connexion au réseau local* 7 :

Statut du média. . . . . . . . . . . . : Média déconnecté
Suffixe DNS propre à la connexion. . . :

Carte Tunnel Connexion au réseau local* 6 :

Statut du média. . . . . . . . . . . . : Média déconnecté
Suffixe DNS propre à la connexion. . . :

I’m sorry it’s in French but i think you can understand anyway.

Fixed the language thing.

Router IP is the gateway IP. Are you trying to run the server on the PC you got that info from?

Yes.

Is the Windows firewall off? Or allowing the right ports through at least?

I tried to disable my firewall and i’m still getting unable to connect to server remote, i don’t need help anymore with the gmod list because, 2players was on my server and i had no idea who they was so my server is in the gmod list.

Is the server up now? What’s the IP/port?

74.58.135.145:27015

Well I can telnet to that port from where I am, so the port is open, and the server’s online. Not sure why you can’t join it…

I can join it lmao gametracker just can’t scan my server and also i can’t connect on my remote console

Oh, you made it sound like ports weren’t opening or something… nevermind, I’m tired… heh

Use www.game-monitor.com; they list server automatically.

Edit:

See?

I assume you do not have a static ip, that is why the “gametracker” site doesn’t work.