Porting textures from FO3 to Gmod?

Ok, so I just got FO3 and decided to try and port something I have been wanting for a while. There was already a Mirelurk model so I just needed the NukaLurk textures ported. I ported the textures so as of now I have 3 NukaLurk textures in my pictures folder. mirelurknuka-cola.dds, mirelurknuka-cola_g.dds, and mirelurknuka-cola_n.dds. When the DDS files are opened in Gimp they look transparent, like this


So, how do I get it to look like a solid material so I can port over to Gmod with VTFedit?

You opened the bumpmap (g or n) dds

No, its just mirelurknuka-cola.dds I opened. Says on the top of the Gimp window

Tried the other two?


Nukalurk G

Nukalurk N (I assume this is the normal material)

For some reason many .dds files don’t open well in various programs, particularly the GIMP. I had problems like this porting stuff from Oblivion: I found the textures show up correctly in Blender, and I think they work in Photoshop.

i think it has something to do with the mask

go into layer > mask > add layer mask and click on transfer layer’s alpha channel

after that go back into layer > mask and click on “disable layer mask”

that should do it

Don’t disable the masks on the normal maps though. The alpha is used to determine the intensity of things like phong on a model.

The Mirelurk’s nuka skin is just a skin that goes over the original skin. Open the original Mirelurk’s materials (non-nuka ones), copy the Nuka layer, and paste it over the original.

Ah, that is it. Thanks for that and thank you to other posters for your info

FYI, Bethesda uses -n for normal maps and -g for glowmaps, which are roughly like illumination maps in Source.

The invisible parts are either the envmap or phongmap (I think they are generally used as the phongmap when ported to GMod), so just save that image as you have it there as a TGA and import that into VTFEdit, when you have it in there it will look correct ^^ (then once you figure out VMT code you can apply the phongmap from the Alpha Channel).

Just as a note the alpha channel of the normalmap is used for the phongmap as default and the alpha of the texture itself is used as the en/illum map (I think). So if you want to use the other way round you must specify. Also if you want something to be transparent while using the alpha channel for one of the other mentioned purposes you must specify the transparency above the other commands.