Possible Pointshop outdated error, not entirely sure.

Server has been crashing like crazy more often than normal, recently transferred over to a managed VDS in Chicago and since then it’s been just crashing alot more often and keeping it down, I literally have to manually stop and start it.

Any help would be appreciated.

Here’s the following error.

[ERROR] addons/pointshop/lua/sv_player_extension.lua:279: attempt to index field ‘PS_Items’ (a nil value)

  1. PS_HasItem - addons/pointshop/lua/sv_player_extension.lua:279
  2. PS_HasItemEquipped - addons/pointshop/lua/sv_player_extension.lua:283
    3. fn - addons/pointshop/lua/sh_pointshop.lua:131
    4. unknown - addons/ulib/lua/ulib/shared/hook.lua:183

if this is the wrong thread, i’m sorry lol.

Reinstall Pointshop.

Do you suggest I just reinstall a clean version of pointshop entirely?

Yes.