Post Init Systems Loading Screen Freeze

Whenever I start up GMOD everything seems to start loading fine. When it reaches “Post Init Systems” about 75% of the way, it freezes and doesn’t give any error or anything. It doesn’t crash the game, it just freezes there and I need to end the process.

I’ve tried restarting my computer.
I’ve tried de-fragging Gmod.
I’ve tried verifying the cache.
I’ve tried Googling this problem many times.
I’ve tried re-installing Steam.
I’ve tried setting my launch properties to -dxlevel 81 and such
I’ve tried verifying ALL of my source caches.
I’ve tried re-installing Gmod (2 times.)
I’ve tried updating my graphics and sound drivers.
I’ve tried deleting the \garrysmod\garrysmod folder.
I’ve also left the game running over night and also under my watch for about 45 minutes. No progress was shown in the loading bar as it was just stuck in “Not Responding” on the task manager.
I’ve tried deleting all GCF formatted things for source games and gmod.
I’ve tried deleting all my source games and reinstalling only HL2 and gmod.

I’ve had this problem for a good three days or so and I would really enjoy playing Garry’s mod again.

Processor = AMD Phenom II x4 940 3.1GHz
OS = Windows XP Professional x64 bit edition. Version 2003 Service Pack 3
Graphics Card = Nvidia GTS/X 250

I’ll be willing to provide more information on my computer if requested and also for the bug. But this is all I can say for it at the moment because it doesn’t give me a HL2 has stopped working or anything.

Please help and thanks in advance!

bump

try going to your C:\Program Files (x86)\Steam\SteamApps\common then take out your garry’s mod folder and put it on your desktop, then proceed to launch garry’s mod from the garry’s mod folder on your desktop (not from steam) this worked for me