Precision Alignment

I’m having trouble with the precision alignment tool in Gmod, when I try to move a one prop to another I get spammed error messages in the console, I don’t know if this is a problem for everyone since my internet has been off for ages, is there a fix for it yet?

Which version are you using and what is the error you’re getting?

Where did you get the addon?

It was the fixed version that someone released a while back, this is the console message I’m receiving:

"[ERROR] lua/includes/extensions/util.lua:26: bad argument #1 to ‘GetPhysicsObjectNum’ (number expected, got nil)

  1. GetPhysicsObjectNum - [C]:-1
  2. IsValidPhysicsObject - lua/includes/extensions/util.lua:26
    3. unknown - addons/precision alignment/lua/autorun/server/sv_precision_align.lua:416
    4. unknown - lua/includes/modules/concommand.lua:69"

Oh, yeah a change in lua in an update broke that a while back… that is fixed in the latest version. http://forum.facepunch.com/showthread.php?t=1239976

Okay, I installed the one on that page on the first link and I still get the same error.

What version does it say you have on the R menu in-game? Should have a version number in the top right corner.

This version states V1.5.

Then you have a super old version installed somewhere… it should read “unofficial v8” if you have my version.

You did DELETE the first one before putting in the new one, correct?

Okay I’ve fixed it and it works great now, cheers mate.

Mark as solved please