Probelm with a friend joining my Gmod and TF2 Server

So I know there’s tons of threads about this, but I can’t find the answer.

My girlfriend can’t connect to me and I can’t connect to her. In Team Fortress 2, I press “Create Server” and do all that jazz correctly, but nobody can join it. The server just doesn’t show up in the server browser, and when I invite her or she tries to join through the friends menu, it just says “Server not responding.” I’ve tried opening ports, joining through console commands and IP addresses, nothing seems to work. I can’t use portforward.com because I don’t have a static IP address. The recommended ports are opened on both my firewall and my router.

On another note, we’re easily able to join our servers in Left 4 Dead 2, not sure if it helps, but there you go.

This is infuriating and I hope somebody has the answer. I offer a supply crate in TF2 to whomever gets it working.

Extreme bumpage.

Type in “heartbeat” and “sv_lan 0” in the console. Oh, yeah, give me the crate tomorrow at around 6:00 :wink:

you say your ip isn’t static, this is required to host a server since the ports will not be correctly forwarded on a dynamic ip.

I’ve hosted TF2 and Gmod a few times as, so here’s what I do.

  1. Start your game through the menu.
  2. In game, open your console and type in “sv_lan 0” and 'heartbeat 1", without the quotes.
  3. Get your IP from here. And give it to the other player.
  4. Have the other player go to their console and type “connect (IP here)”, also without quotes.

That should get your server to work.

also open the ports and set these ports forwarded to your static, reserver IP

Or, you can send them a game invitation.

I’ve found that the console works better. But that works too.

Thank you for all the replies, but we’ve tried everything here to no avail. Apparently it’s just because we both have dynamic IPs.

Surprised No one has said something about using hamachi,

Unmanaged Version

I’m not wizz at this but it makes a stable server between you and your friends,

Step1:Dl Hamachi
Step2:Create Network
Step3:Tell your friends the Name/Pass
Step4:Create Game
Step5:Make sure they right click your name or whom ever is hosting and click copy address, then paste it in console (ingame) so it shows up like this.

connect 5.1870.23.2123.(What ever your ip is)

I’m practically sure this will work 100%

I’m confident Hamachi will work, but I’m not able to try it right now. Tomorrow I’ll try it out and if it works you’ll get the crate and my undying man-love.

Lol I don’t need the crate keep it :v:

Still no dice, but progress is being made. We both got Hamachi and we’re connected to each other, and did exactly as you said, but now she’s getting the message “LAN servers are restricted to local clients (class C).” whenever she tries to join through the console. I’m not quite sure what that means, any suggestions? The crate is still up for grabs since Brandon is such a noble person.

Also, I tried sv_lan 0 and heartbeat, as well as setting the region.

Have you tried swapping round and maybe her hosting the server, sorry if you’ve already said this.

Hamachi should work though, I use it with a friend and we both have Dynamic IPs but it works perfectly.

I remember once I got the lan error, I can’t remember what I did but I think I just restarted it then connected to my friend and joined, success. You could also try fiddling with the Hamachi settings, such as security (she may not be trusted on your network)

One last thing, just to make sure, do you have Hamachi running while you play Gmod? I know it sounds stupid.

Odd all I know Good Luck with the Issue v:v:v