Problem downloading files from all servers

A few days ago I went on holiday to Christchurch for 4 days (Christchurch is that place in New Zealand that had loads of Earthquakes and stuffs) and when I returned hungering to stab some afks on Trouble in Terrorist town and play some Morbus, I found my Garrys Mod refused to download any files from a server, I first noticed it when I couldn’t download the lua cache for TTT (downloaded it from fdl.kickasservers.net later).

I tried a few other servers thinking it could’ve just been the KickAss servers, but i’ve had this problem with every server i’ve connected to.
Today I connected to the Morbus server since I downloaded the maps for it and the Cache, then found all the models missing. So I was a giant error attempting to kill Giant Errors.
Just did a clean install of Garrys Mod (wipe all files, then re-install) and the problem still persists :C
If anyone knows of a possible fix I am glad to try anything (and I do mean ANYTHING) to get it working again.

Note:
Deleting Steam/Steamapps/Skov/Garrysmod does not fix it.
Deleting the cache folder does not fix it.
I have allowed files to be downloaded from servers
Deleting Clientregistry.blob did not work

Also:
If anyone has a program which allows you to download whole directories off a webserver that may be a temporary fix.

Same thing is happening to me, my friend said it could possibly be a virus, so do a scan just in case

Seems very odd if you have allow on that. It might be that the game doesn’t save your settings to the config.cfg.
Head to the cfg folder in your garrysmod folder and open up config.cfg and find “cl_allowdownload”. Make sure it is set to 1 and save it. If it already is, I don’t have any solution for you.

A 3rd party program to download all files from a web server is not that great to get, since most of the server owners do bz2 compress their files which forces you to decompress each file and then add it to your garrysmod folder.

Did a scan, nothing was found.

[editline]4th February 2012[/editline]

Found it, it is set to one already :frowning:

Rename the first gmod folder to something like “garrysmod-old” then start gmod

join a server if its still buggered then you might have a firewall issue that preventing http downloads.

Tried that, I’ll look into the Firewall to see if theres any problems.

developer 4
download_debug 1

join a server where there isn’t a lot of content, disconnect once you get in, paste output

net_maxfilesize 64

try that

] net_maxfilesize
“net_maxfilesize” = “16” min. 0.000000 max. 64.000000

  • Maximum allowed file size for uploading in MB

he’s downloading