Problem running rust on nvidia with optimus?

Fps seems low for my notebook, I read somthing about rust not working well with cards that have optimus tech so im thinking maybe its running off my integrated card? Anyone have a work around? Im pretty well computer iliterate but i figured this computer should be powerfull enough to run this game no problem? so any help would be much apreciated.

Specifications
DISPLAY
Screen Size15.6 Inches
Native Screen Resolution1920 x 1080
LED Backlit DisplayYes
Touchscreen DisplayNo
3D Capable DisplayNo
PROCESSOR
Processor TypeIntel Core i7-4700MQ
Processor Cores4
Processor Speed2.4 GHz
Processor Cache6 MB L3
STORAGE & MEMORY
Hard Drive Capacity1 TB
Hard Drive Speed (Revolutions Per Minute)5400 rpm
RAM Size16 GB
RAM TypeDDR3
RAM Speed1600 MHz
RAM Slots2 (0 Available)
Optical DriveDual Layer SuperMulti DVD+/-R
Built-in Memory Card ReaderYes
Memory Card Reader - Compatible Memory TypeSD; SDHC; SDXC; MMC; Mini SD; Micro SD
GRAPHICS
Graphics ChipsetNVIDIA GeForce GT 740M with Optimus
Video Memory ConfigurationDedicated
Dedicated Video Memory Size2 GB

To be clear, this game is incredibly unoptimized. Some people with mid-ranged specs boast about high framerates, and some with mid-high specs claim sub-average framerates. There is no universal user based fix for this. Keep in mind, this game is an early release alpha. They are working on several framerate tweaks, such as rebuilding how the sky is rendered, but I wouldn’t expect the game to run flawlessly for another year or so.

EDIT: Also, there is already a thread for this.

  1. Right click on your desktop and click “Nvidia Control Panel”
  2. Click “Manage 3d Settings” on the left and then the “Program Settings” tab on the right.
  3. Click “Add” and select “rust.exe”.
  4. Under “Select the preferred graphics processor for this program” select “High Performance Nvidia Processor”.
  5. Click Apply, close the window, enjoy Rust.

Thanks i will try this when i get home

[editline]6th February 2014[/editline]

Actually this is a thread about a specific issue with a specific graphics card, not a general what system are you running thread. I think a seprate topic was warrented.

I was going to suggest what draxus said but he beat me to it. I bought my girlfriend a similar spec laptop with GT740 also, she was playing neverwinter and experiencing the same issue

Basically if the pc doesnt determin the game needs the dedicated video card it will use the crappy one, and it does a crap job of determining which one to use. To be safe on all games you should really use the above method to force the laptop to use the dedicated card

Also Freenote is was pretty obvious he wasnt asking if his laptop could play it if u even read the specs

i7, 16gb ram, GT740…pretty obvious he can run the game, and pretty much any game at the moment

Just tried it out and worked like a charm way better performance! Just a note for anyone who needs to do this step 3: select rust.exe isnt an option however you can select steam.Exe which has the desired affect. Thanks for the help guys much appreciated as this is the first computer ive ever owned and pretty much everything I know about hardware I learned last weekend with google before I bought the machine on sunday. If your ever in ontario I will owe you a beer