Problem with CakeScript in multiplayer

Hello! I work on a modified version of the role play CakeScript. But I have try to start a multiplayer game as a test, and when I chose my character by clicking on his picture, the character menu get closed but it does not choose me my character. And here’s the error message:
[gamemodes\cakescriptg2\gamemode\player_util.lua:257] attempt to index field ‘?’ (a nil value)

I went to see the place where there had to be wrong, so here are:
function meta: RefreshInventory ()
self: ClearInventory ()

for k, v in pairs (CAKE.GetCharField (self, “inventory”)) do
umsg.Start (“addinventory”, self);
umsg.String (CAKE.ItemData [v]. Name);
umsg.String (CAKE.ItemData [v]. Class);
umsg.String (CAKE.ItemData [v]. Description);
umsg.String (CAKE.ItemData [v]. Model);
umsg.End ();
end
end

It is this line that is known buggy:
umsg.String (CAKE.ItemData [v]. Name);

I do not understand where is the problem. In addition, the rp work perfectly n single player.

Help me please! Thank you very much! :slight_smile:

Note: I tried to start a multiplayer game with the unmodified version of CakeScript (original version) and I got the same error.

Okay, so someone who got CakeScriptG2 could launch a multiplayer game and tell me if the same error? Thank you!