Problem with connecting to servers

Even though I mostly play in SP, I sometimes would like to play in multiplayer. But most of the time I wait, wait, wait, it to connect to the server, mostly because it has to download everything, then I wait, andwhen I return because of long waiting, a message with “dexazoid Timed Out”(or something similar). Then I press “Close”, try to connect again, And the same message pops up. But it doesn’t download all that stuph again(so it takes less time, I told you that to make it clearer).


TL;DR

: I try to connect, it phails, I try to reconnect, it phails, and always a message with “dexazoid Timed Out” pops up.

Sometimes I can connect, but rarely. And I can ALWAYS connect to Lithuanian servers(from my country), but there are no good servers here.

Also, if that matters, I am using a wireless connection, but when downloading stuff, it seems just as fast as a wired connection.

HALP.

Are you sure you’ve got all the correct ports forwarded?

You need:
[TCP: 27014-27050] and [UDP: 4380 and 27000-27030]

Furthermore, connect in via cableif you can :stuck_out_tongue: , Wireless works but it’s not a good way to go for online gaming, not always stable enough.
Though, i don’t think being connected through wireless causes this particular issue .

Thanks.

I don’t think so, because the same modem that cables connect to also has the antennae.

I will try.

Yes, but to get from the antennae on the modem to the one on your computer, the signal has to travel through air (and other stuff) littered with random signals :).

Hope it worked out for ya

Tried both.

Connection - wired, protocol - with ports open.

Please tell me the EXACT setup I should be using.

well i can’t tell you EXACT since i don’t know your router or your isp, nor your OS for that matter :)…
But optimal would be that all the ports mentioned above are open (check if they are actually open, don’t trust the router :p) and of course running on cable.

http://www.canyouseeme.org/ is lovely for checking if ports are open.