Problem with Expression2

Hello everybody,
Excuse me for my faults and small vocabulary, I’m french…

So, to begin (I’m very conventional) my (little) system spec:

Processor : Intel Core 2 Quad => 2.33GHz
RAM : 3Go
GPU : Nvidia 9500GS
OS : Windows Vista

My addons :

-Scars
-PlayX
-Propeller Engine
-gm_buttes
-gm_bigcity
-gm_adventurers
-Clip Tool
-wire, wire model pack, Adv Dup, wiree (with Glua.net, Tortoise SVN doesn’t want to work for X reason)
-Nuke
-SmartSnap
-phx3
-StackerTool
-WeightTool
-FinTool

What’s my problem ?

When I lauch the Singleplayer game (I didn’t try in Multiplayer game), two messages appear in the concole :

Couldn’t include file ‘core\e2lib.lua’ (File not found) (@addons\wire\lua\entities\gmod_wire_expression2\shared.lua (line 14))
Couldn’t include file ‘core\init.lua’ (File not found) (@addons\wire\lua\entities\gmod_wire_expression2\shared.lua (line 19))

And, when I want to spawn a E2 gate, she’s inactive (none) and red.

The menu says “Loading extensions, please try in few seconds…” , I wait, I wait, nothing change…

This message appear in theconsole too when I spawn the gate :

[addons\wire\lua\wire\client exteditor.lua:2672] attempt to index global ‘wire_expression2_funclist’ (a nil value)
[

I don’t know where is the problem, I reinstalled wire with Glua.net, I reinstalled the game…

Thank you for your attention !

[editline]22nd March 2011[/editline]

Have you tried reinstalling WireMod?

It looks like wiremod has a problem. Try this program: http://www.tezzanator.net/programs/garrysmod-auto-svn-updater/

It will download the latest version of wiremod through SVN. Be sure to remove your current wire folders.

Thx you dArKnEsS_2, the program solved my problem, I think I just forgot to delete the old folders, and the problem was still here :confused:

Problem resolved :slight_smile: