Problem with Gmod physgun and some textures

Hi folks,

I did fresh install of Windows 8 yesterday, and I formatted Steam partition too. Today I have downloaded Gmod, along with Half-Life, CSS and TeamFortress2. However some textures went missing, lua errors, physgun and background are flashing and so on. Before reinstall everything worked fine.

Steps I tried to fix the errors:

  • Reinstall the game (not worked)
  • Disabled all addons and reinstall again (not worked)
  • I’ve verified cache for CSS, TF2, HL2 and Gmod (not worked).
  • Reinstall DirectX and latest Nvidia graphic driver for my card (320.18)
  • Tried running Gmod in DirectX8 mode (not worked)

My configuration:
-CPU: Intel Core i5 2500k
-RAM: 6GB
-Graphics: MSI GeForce 460gtx Hawk (1GB DDR5 memory)

Erros I get in console, just after I join:


Initializing Awesomium..
No Kinect SDK
Lua JIT is DISABLED!
Unknown command "cl_thirdperson"
Unknown command "hud_showemptyweaponslots"
Unknown command "sv_backspeed"
PREP OK
Attempting to bind a texture to an invalid sampler (4)!
Attempting to bind a texture to an invalid sampler (4)!
Attempting to bind a texture to an invalid sampler (4)!
Attempting to bind a texture to an invalid sampler (4)!
Attempting to bind a texture to an invalid sampler (4)!
Attempting to bind a texture to an invalid sampler (4)!
Attempting to bind a texture to an invalid sampler (4)!
Attempting to bind a texture to an invalid sampler (4)!
Error, bad server command lua_error_url ''
Lua JIT is DISABLED!
Using map cycle file 'cfg/mapcycle_default.txt'.  ('cfg/mapcycle.txt' was not found.)
Nav File is wrong or something (4)
Garry's Mod

sandbox
gm_construct
1
76561198046173907
Attemped to precache unknown particle system "generic_smoke"!
Requesting 1 lua files from the server
Warning: WorldTwoTextureBlend found on a non-displacement surface (material: gm_construct/flatgrass). This wastes perf for no benefit.
clientside lua startup!
Lua JIT is DISABLED!
Requesting texture value from var "$dummyvar" which is not a texture value (material: NULL material)
No such variable "$phongtint" for material "models/weapons/c_arms_citizen/c_arms_citizen_sleeves"
Error: Material "models/weapons/c_arms_citizen/c_arms_citizen_sleeves" : proxy "Clamp" unable to initialize!
No such variable "$phongtint" for material "models/kleiner/players_sheet"
Error: Material "models/kleiner/players_sheet" : proxy "Clamp" unable to initialize!
No such variable "$phongtint" for material "models/kleiner/players_sheet"
Error: Material "models/kleiner/players_sheet" : proxy "Multiply" unable to initialize!
No such variable "$phongtint" for material "models/kleiner/players_sheet"
Error: Material "models/kleiner/players_sheet" : proxy "Clamp" unable to initialize!
Attempting to bind a texture to an invalid sampler (4)!
Attempting to bind a texture to an invalid sampler (4)!
Attempting to bind a texture to an invalid sampler (4)!
Attempting to bind a texture to an invalid sampler (4)!
Attempting to bind a texture to an invalid sampler (4)!
Attempting to bind a texture to an invalid sampler (4)!
Attempting to bind a texture to an invalid sampler (4)!
Attempting to bind a texture to an invalid sampler (4)!
Attempting to bind a texture to an invalid sampler (4)!
Attempting to bind a texture to an invalid sampler (4)!
Attempting to bind a texture to an invalid sampler (4)!
Attempting to bind a texture to an invalid sampler (4)!
Attempting to bind a texture to an invalid sampler (4)!
Attempting to bind a texture to an invalid sampler (4)!
Attempting to bind a texture to an invalid sampler (4)!
Attempting to bind a texture to an invalid sampler (4)!
Compact freed 495616 bytes
Redownloading all lightmaps

Graphic problems:

CloudApp — Not Found
CloudApp — Not Found

Also, texture render quality randomly drops and physgun is weirdly flashing, along with background materials.

I had the same problem. After updating to steam pipe, Gmod was using Dx8. Simple fix is to put - dxlevel 95 in your startup perams and start gmod. Then remove it from the perams and restart the game. You will notice the textures will look better and the flickering will stop.

Hey thanks, hemirox. I just tried that and nothing good comes out of it. Any other hint?

I should add that I’m using Windows 8 64-bit. Everything is completely same like a last setup.

Take a screenshot of your advanced video settings menu, and post it back here.

Make sure to put -dxlevel 95 with no space in between the dash and dxlevel.

Thanks for feedback guys. I solved it with “-dxlevel 101” option.