Problem with includes\init.lua -- failed to create gmod_thruster?!?

After a several month hiatus of hosting a gmod server, I decided to bring it back online as I have a new server box and a faster internet connection. So everything is installed and updated, and the server is live. I go to spawn a few contraptions and get this:


AdvDupeERROR: CreateEntity failed to make "gmod_thruster", Error: includes\util.lua:71: bad argument #1 to 'PrecacheSound' (string expected, got boolean)
AdvDupe: Sending this ErrorMsg to Player [1][Cornflake]
AdvDupe-ERROR: "Failed to make "gmod_thruster""
AdvDupeERROR:Created Entity Bad! Class: gmod_thruster Ent: 111

On every… single… contraption I have saved with thrusters, it spawns and they all fall off, non-functional with the error “failed to make gmod_thruster”. I also tested a few other users’ saves and the same result. Some of my contraptions are as recent as September 2009!

I spent the wee hours this morning doing some testing. The duplicator has recently been updated (to v0.84) and I tested with both the new and old (v1.83) and the same result. I even copied the exact version of Wire that was being used to create the save, same result. The only conclusion I can come up with from testing multiple versions of wire, and the error, that a recent gmod update is the culprit. I even went as far as renaming my old gmod folder, as the protocol goes but it did not change anything.

Anyone else having this issue and feel like ranting? Maybe we can come up with a solution? I will post more testing later after work. What a way to ring gmod into the new year, eh?

Latest gmod update changed thrusters.

Perhaps the dupe saves can be modified to avoid this, if the parameter in the saves that’s causing the error can be identified?

If only we have a dupe of just a thruster before the update.

having the same problem -.o

Wouldn’t work anyway.

Well it’s obviously a problem with a parameter in the dupe file. So im thinking it could be fixed, albeit at least for a very simple save…

Spawning my 250 prop space shuttle… with 34 thrusters finely tuned to push it in perfect straight lines… all fall to the ground…

And thats AFTER i had to redo the weight on every single one of them to get em to push at all after the orangebox update.

Oh garry what is it you have against thrusters?

Maybe the advanced duplicator could be modified to convert old thrusters to new ones?

That happens to me as well. But that happens on my old computer, so it might work on this one. It was very annoying.

Due to a recent update all my contraptions are fucked.

All thrusters don’t work.
Wire has been updated and the wire needs to be redone everytime I spawn something.

This can be fixed quite easy. Who made the first adv dupe?

I’ll try and fix it

I have a long manual way of fixing the problem, when you aim at the thruster it still tells you all the thruster settings set your dupe to spawn frozen, find the thrusters, copy and replace them. I haven’t tried it myself but i can’t see why it wouldn’t work.

Where did you get it? it. Me either.

get what, the idea? To be honest i dont know, i just thought it might work. :stuck_out_tongue: