Problem with my biggify command.

So I am trying to make a biggify command for my gamemode to try out the resizing, the code is located in a shared autorun file. Also I can already guess that on the second line it should be something else than LocalPlayer(), just dont know what. Tell me if you know! :slight_smile:

Here is the commands code.



concommand.Add( "biggify", function( ply, cmd, args )
	for k, v in pairs( LocalPlayer() ) do
	local bottom, top = v:GetHull()
	local bottomduck, topduck = v:GetHullDuck()
	ply:SetHullDuck( Vector( bottomduck.x * 1.1, bottomduck.y * 1.1, bottomduck.z * 1.1 ), topduck.x * 1.1, topduck.y * 1.1, topduck.z * 1.1 ) )
	ply:SetHull( Vector( bottom.x * 1.1, bottom.y * 1.1, bottom.z * 1.1 ), Vector( top.x * 1.1, top.y * 1.1, top.z * 1.1 ) )
	ply:SetModelScale( ply::GetModelScale() * 1.1 , 0 )
	ply:SetRunSpeed( ply:GetRunSpeed() * 1.1 )
	ply:SetWalkSpeed( ply:GetWalkSpeed() * 1.1 )
	end
end )


Here is the error.



[ERROR] addons/feedandgrow/lua/autorun/resizing.lua:5: unexpected symbol near ')'
  1. unknown - addons/feedandgrow/lua/autorun/resizing.lua:0


[lua]
ply:SetHullDuck( Vector( bottomduck.x * 1.1, bottomduck.y * 1.1, bottomduck.z * 1.1 ), topduck.x * 1.1, topduck.y * 1.1, topduck.z * 1.1 ) )

[/lua]

Should be

[lua]
ply:SetHullDuck( Vector( bottomduck.x * 1.1, bottomduck.y * 1.1, bottomduck.z * 1.1 ), topduck.x * 1.1, topduck.y * 1.1, topduck.z * 1.1 )
[/lua]

Unless you planned to add another Vector() in there and just forgot then you forgot the Vector()

Ohh didnt notice that! There was supposed to be another vector after that, thank you!