Problem with particles in my mod

Hello,

I made a map with the Episode 2 Hammer for my singleplayer mod including some info_particle_system with a particle system named “Rain_01” that I found in in the rain.pcf file.
When I launch the map in Episode 2, everything works fine, here’s a screenshot :

http://image.noelshack.com/fichiers/2014/43/1414110813-rake-menu0002.jpg

I placed this same map in my mod folder, imported all custom content then I launched it with my mod. All is working except the particles.
Here’s a screenshot of what it looks like in my mod :

http://image.noelshack.com/fichiers/2014/43/1414110863-rake-menu0000.jpg

If you look closely, you can see a small particle on the yellow line in the middle of the road exactly where the big rain particles are supposed to be.
I launched my mod in tools mod and saw that the rain particles are working fine in the particles editor, but for some reasons they don’t in-game.

About my mod :
It’s supposed to be an Episode 2 singleplayer mod, but I had to change some lines in the gameinfo.txt because of a “Could not load library content” message when I was launching the mod.
Here’s the gameinfo.txt :

I really need some help about this, the map athmosphere is much better with the rain effects.

Do you have a particles_manifest.txt in your mod?

Yes, I have the particles_manifest.txt with all the pcf files in my particles folder. I added the pcf files in the txt file.

Follow this page: https://developer.valvesoftware.com/wiki/Particles_manifest.txt

Due to the recent Steampipe update, particles now require VPK intergration.

Particle systems must be registered in a manifest file. These are:
particles\particles_manifest.txt
maps<map name>_particles.txt (per-map)
particles<map name>_manifest.txt (per-map)

Create a “custom” folder in your mod.
and pack these three folders into .vpk then put it into “custom”
it should be work, at least it works for me.

An ugly demonstration:
http://s29.postimg.org/sx2ex18o3/2014_10_24_00001.jpg

Hope it helps

Those screenshots look very comfy

Thanks for the help, but unfortunately it still doesn’t work for me, maybe I failed somewhere. I think that my problem is because of the gameinfo.txt file. I had to change the SteamAppId from 420 (which is Episode 2 Id) to 218 (which is Orange Box Id) because I had a “Could not load library client” error message when launching the mod. So my mod is not base on Episode 2 anymore, but this is my only solution to make it work.

Try to export all partcles from offical files and put it into your mod.
if i were you i will still prefer ep2 which the engine is newer.

I already exported all particles from official files but it doesn’t change anything.
I’m trying to use Episode 2 base, but here’s what happens when I do and I launch the mod :

http://image.noelshack.com/fichiers/2014/43/1414168071-ep2-error.png

Then it crashs. I really want to use episode 2 as a base for my mod but this error is blocking me.

Have you tried verify it as it said?
or repair the steam client service?

and what version of engine you’re using?

I can’t verify a mod, but I verified episode 2 cache and it doesn’t changed anything.
And I’m using the Source Engine 2007 for the mod.