Problem with skybox and water

Hi i am making a map which is a remake of gm_construct, yes i know there are too many remakes out there, but this map has a twist to it, so dont have a go plz! Right basically i downloaded the so called original vmf of gm_construct but when i load up the map without any modifcations, after compiling it with a different name i get the follwoing problems:

  1. The water texture is just clear
  2. And when i look at part of the skybox it has the problem where it draws the enitre screen and what its drawn stays there basically like not having a skybox there at all but another part works.

I am not a new mapper but nor am i an expert, is this a leak? any help much apprieciated!

Did you compile with vis and rad?

Yep normal on both of them.

*Part of the skybox works its only when you look in a certain direction that it doesnt.

Paste the compile log.

Ok Here it is…


Code Removed...

Point Entry and follow it to the leak?

i may have found the problem… give us a sec to see if this fixes it…

Map>load pointfile follow the red line to the void and patch it.

ok problem solved, thanks everyone for help was a leak and is now patched all works now :slight_smile:

Hello again! i was wondering if any of you could help me with a prolem with the same map, i ignored it till now, even though the VMF i downloaded says its the original i have a problem where the gm_construct/grass meets the gm_construct/grass-sand instead of merging like they did in the orgininal they jusst look ugly heres a pic…

http://www.lightning-intelligence.webspace.virginmedia.com/SAND%20GRASS%20PROBLEM.jpg

Paint alpha. Also that water texture is ugly.

Its cus i screen shot it from hammer, as it looked the same in game and out, and i cba to open the game haha

I was saying it isn’t a dx9 water.

lol yep i havent downloaded any new textures its just one of the ones that came with source 2006, anyway i painted alpha and smoothed it and works like a charm, thanks again :slight_smile:

You should be using 2009. Its a much better engine. And afaik the construct texture is dx9 by default.

I do use 2009 engine but the materials are configured incrrectly and havent been able to get the new ones!!! and im very glad you mentioned that, is it possible to get TF2, CS:S, and half life 2 + episodes materials all in one go because i am unable to use all of the textures in one go…

Refresh SDK Content bro, I think that should work, as far as getting textures all into one game, just extract them from the games gcf file and place them in the directory of the game you’re mapping for.

Refreshing doesnt work but oh well, and OMG i cant believe i didnt think of that lol GCF Scape here i come :stuck_out_tongue:

Haha, don’t know what to suggest for the first thing but glad I helped for the second :smile: