Problem with Source lighting/Shadows

Hey guys, Just a small problem here. Im trying to get a more realistic shadow from a plant prop but as usual its just a huge shadow that looks nothing like the plant. I remember a way of changing this in the compiling so it traces around the edges or something like that, but heck if i can remember how to.
Anychance you guys can help?

I’m not a mapper, but you have to disable its shadow somehow. I remember that much.

the thing is i want the shadows, its not as easy as throwing in a shadow_control entity if i remember correctly theres a few lines you have to put into the compiling script

Just go into the properties for the prop, and disable shadows from there.

I dont want to disable the shadows, i want to keep them but make them better looking.

Im pretty sure it had something to do with lights.rad

Decrease the lightmap scale on the face you want detailed shadow with the face editor. Set the lightmap value to something like 2. Or 1.
But don’t do that to all faces, as it increases compile time and the .bsp filesize.

If it still looks ugly, it’s because that models doesn’t give out a detailed enough physmodel for shadow. In that case you’d have to either disable shadows on the prop, or live with a blurry shadow.

Well, this I guess

yer i had lightmaps hanging around at 4 in that area i guess disabling shadows will have to be the way to go

You can try compiling with
-StaticPropLighting -TextureShadows -StaticPropPolys

But it looks like you already are.

I tryed that it made no difference except for making it take longer to compile

Because static props are getting properly lit.

Are you compiling with -final also?

nope coz its not the final compile lol

ill give it a dirty crack

[editline]13th March 2011[/editline]

Well i finished it anyways, its a neat little map which is a car shop in a little section of a city with citizens walking around - its made for a youtube video

Don’t know if you were kidding or not, but -final is a vrad parameter that calculates light bounces and such in more depth FYI.

yer coarse i am i use it alot XD