Problem with Specular Map

I don’t even know what the hell is wrong here.

Screenshots in game, Cubemaps built.

http://img689.imageshack.us/img689/113/hallwaysraised0002.jpg[/media]
[media]http://img10.imageshack.us/img10/5722/hallwaysraised0003.jpg[/media]
[media]http://img198.imageshack.us/img198/7873/hallwaysraised0004.jpg[/media]
[media]http://img689.imageshack.us/img689/6974/hallwaysraised0007.jpg[/media]
[media]http://img192.imageshack.us/img192/2088/hallwaysraised0009.jpg[/media]

Textures Themselves
Base
[media]http://img697.imageshack.us/img697/9171/doorleveldoor01.jpg[/media]
Bump
[media]http://img689.imageshack.us/img689/5527/doorleveldoor01bump.jpg[/media]
Specular
[media]http://img192.imageshack.us/img192/5096/doorleveldoor01spec.jpg

Note that these were ripped directly from a game so there is nothing wrong with them.

And the VMT



"LightmappedGeneric"
{
	"$basetexture" "Penumbra/door_residental"
	"$bumpmap" "Penumbra/door_residental_bump"
	"$envmap" "env_cubemap"
	"$envmaptint" "[0.3 0.3 0.3]"
	"$envmapmask" "Penumbra/door_residental_spec"
	"$surfaceprop" "Wood_Solid"
}


Any help would be greatly appreciated!

Sexy.

That’s not a specular problem. That’s the Missing texture checkers for a missing normal map.

Why would it be like that for a normal texture, I have the bump map there. Don’t I?

Mind explaining please?

It could be a few things: VTF corruption, misplaced file, incorrect name in the VMT… double check everything. The telling sign here that it’s the normal map is that the cubemap is distorting along the checkers. This is another: [img_thumb]http://img689.imageshack.us/img689/6974/hallwaysraised0007.jpg[/img_thumb]. The purple/black checkered texture is telling the renderer to look the wrong way for lighting. You wouldn’t see this if it were a spec map problem.

This pic throws me off, though: [img_thumb]http://img10.imageshack.us/img10/5722/hallwaysraised0003.jpg[/img_thumb]. I don’t understand why one door would work and the other one wouldn’t unless they’re two different textures.

I think you should take a step back. Comment out the normal map and see how it looks then. If you’re still seeing checkers, but they aren’t distorted - more like perfectly even wet spots - you’ve got a spec map problem. Do vice versa and if you see differently lit checkers, you’ve got a normal map problem.

Allright I’ll try checking this out

I’ve been having this problem with most reflective textures in Garry’s mod since the summer update. Anyone else start experiencing this around that time? If it helps I run Windows 7 64-bit.
This never happened before this summer and it was immediate(and permanent):suicide: after the update. Any thoughts Facepunch?

oops, sorry for thread necro.