Problem with tmysql on linux

Hello.

So I’ve been trying to get the gamemode cider to run correctly on my linux machine (Its CentOS). I added few features into it on my windows PC and it was running just fine.
When I moved it over to the linux I started to have problems with the tmysql. I searched a bit and found a post where AzuiSleet was giving some link for some boost files. Well, I took those and installed them into my linux server, but noticed no difference in the server. Still the same error and everything.

I’m not quite sure if I managed to install the files correctly whatsoever. I’m not so familiar with Linux and I prefer installing everything through yum rather than from zip or tar file.

Anyway, I was hoping to get some help from here, if someone could help me solve this issue.

So heres the error I get when I try to connect to the server.


[gamemodes/cider/gamemode/core/libraries/sv_player.lua:585] attempt to index global 'tmysql' (a nil value)(Hook: PlayerInitialSpawn)

And heres what the sv_players.lua line 585 looks like.


tmysql.query("SELECT * FROM "..cider.configuration["MySQL Table"].." WHERE _UniqueID = "..uniqueID, function(result)

So yeah, any help on this would be appreciated, thanks.

Bump. Could anyone help on this?

Bumping this up again.

Looks like it’s not loading the module.

Did you get the module from here http://gmodmodules.googlecode.com/svn/trunk/gm_tmysql3_boost/ and where did you put it

I didn’t get it from there, nope. It came with the gamemode. The file was just named gm_tmysql.dll and I placed it into lua/includes/modules/ folder. I’ll try adding that instead and see if it starts to work.

Okay, now something strange happened. The gamemode itself wont load at all, but gives this kind of an error.


error loading module 'tmysql' from file '/home/gmod/srcds/orangebox/garrysmod/lua/includes/modules/gm_tmysql_linux.dll':
        libboost_thread-mt.so.1.38.0: cannot open shared object file: No such file or directory
[cpp]
There was a problem opening the gamemode file 'cider/gamemode/init.lua'

Whats up with it now?

I placed libmysql.dll to orangebox/ folder and the gm_tmysql_linux.dll into lua/includes/modules/

try installing boost libraries?

I’m running CentOS 6, so I ran this yum install boost boost-devel boost-doc
However, this didn’t fix the problem. Where exactly can I find these boost libraries then?

Edit
So I went back to searching and I can’t find anything new for this.
The only thing I can find is the same I found before, which is the post by AzuiSleet.
http://www.facepunch.com/threads/1059858?p=30299965&viewfull=1#post30299965

It has basically the link of the files which belong into /usr/lib as far as I am aware, I placed those files in that folder, but nothing really helped. The server was restarted aswell, but nothing.

Okay, so here we go again.
Apparentally I’ve got the boost libraries installed now on the machine as its not complaining about the tmysql at all. However, it doesn’t seem to load the information from the database at all.

I believe the issue is because of this.
http://www.facepunch.com/threads/1059858?p=28133860&viewfull=1#post28133860

Apparentally I’d need to download that package, which I did. Though, I didn’t understand from the post whether I should only take the libmysqlclient.a and libmysqlclient.so.16 or the whole folder(s).

So if I’d place those files into the /usr/lib/ I’d need to use symlink to create the symbolic link?

Anyway, if anyone could be kind enough to help me with this (tell me which files to use and how to create the symlink), I’d appreciate it a lot.