Problem with water!

Basically all this is… Is a map using gm_construct/water. As you can see… It partially works. Testing with CS:S for Gmod.

http://img38.imageshack.us/img38/4938/45407432.png

The following is that file’s information.



"Water"
{
	"Water_DX60"
	{
		"$fallbackmaterial" "gm_construct/water_dx7"
	}
	
	"$abovewater" 1
	"%compilewater" 1
	"$forceexpensive" 1
	"$reflectentities" 0
	"$envmap" "env_cubemap"
	"%tooltexture" "nature/water_frame01_normal"
	"$refracttexture" "_rt_WaterRefraction"
	"$refractamount" "1"

	"$reflecttexture" "_rt_WaterReflection"
	"$reflectamount" "0.4"

	"$scale" "[1 1]"

	"$bumpmap" "nature/water_coast01_dudv"
	"$normalmap" "nature/water_coast01_normal"

	"$surfaceprop" "water"
	"$bottommaterial" "gm_construct/water_beneath"
	"$bumpframe" "0"

	"$fogenable" 1
	"$fogcolor" "{7 66 58}"
	"$fogstart" 0
	"$fogend" 1024.00

	"$scroll1" "[.01 .01123 .05]"
	"$scroll2" "[-.015 .015 .01512]"

	"Proxies"
	{
		"TextureScroll"
		{
			"texturescrollvar" "$bumptransform"
			"texturescrollrate" .02
			"texturescrollangle" 25.00
		}
		"WaterLOD"
		{
		}
			
	}
}


Screenshot of my problem below. To the right is in the editor and to the left is in-game. If anyone can help me… That would be wonderful!

Have you tried using the orangebox for it?

I tried this but I get the same effect.

Hmm did you get the beneath texture too?

Use cubemaps. This happened because you didn’t use them.

Build cubemaps?

No add cubemaps. He has to add cubemaps on map.

If you take a look, its a problem with the material.

do you use a custom Water texture?

It’s missing the normal map.