Problems Galore: Hooray!

First:
Every time I quit Gmod it takes about five minutes before going to desktop with the message “hl2.exe has stopped working.” Therefore none of my binds/other changes don’t save.

Second:
Can’t rotate shit with the phys gun.
I tried resetting all binds and re-binding E multiple times.

Third:
When I’m playing sandbox in SP, I hold or press E and turn just a bit and once I let go of E, the camera snaps back to where it was when I first pressed E. It’s useful in some situations, but to me it’s mostly annoying.

Fourth:
I can’t mount Ep 2. I have it installed and have played it before. Also note that it was munted before the update.

Fifth:
Episode 2 crashes on start up.
Now, before you say “Well duh. That’s why you can’t mount it derp” it worked fine before the update. The models were spawnable, dynamic lighting worked, etc.

Why god. Why.

I think the update caused a few problems.
Alternately, try moving all your addons to a holding folder, then see how gmod works.

Yea the update fucked you over, now you just have to wait it out or try fixing shit and risk fucking you GMod.