Problems with custom textures

No…

In your HL2:DM materials folder, make a folder called “custom”. Drop your VTF and VMT inside it. Make sure to copy over what I pasted into your VMT (You can edit it with Notepad). If Hammer is open when you’re doing this, close it and reopen it afterwards.

I did this, but I haven’t recompiled it. It’s still black in hammer.

So your set-up is now as follows?:

materials/custom/Porno_Shop_Sign.vtf
materials/custom/Porno_Shop_Sign.vmt

with the VMT saying:


"LightmappedGeneric"

{
	"$basetexture" "custom/Porno_Shop_Sign"
	"$surfaceprop" "metal"
}

Yes.

[editline]06:13PM[/editline]

Just recompiled and it’s the same as always.

Are you suuuure?

http://img23.imageshack.us/img23/4355/ss20091005203010.jpg

Yes :frowning:

[IMG]http://i233.photobucket.com/albums/ee289/ndsfreak/yesimsure-1.png

The LightmappedGeneric shader has no idea what the “Porno Shop Sign” key is supposed to do.

Try using the $basetexture key instead (and $surfaceprop instead of “Metal”).

Edit: And try using the right path to the texture as well.

That’s what I had before. Whenever I do that, it just is the checkerboard pattern.

Because it needs to be materials/custom/porno_shop_sign

Apparently not. Like I said, replace the contents of your VMT file with EXACTLY what I have here:


"LightmappedGeneric"

{
	"$basetexture" "custom/Porno_Shop_Sign"
	"$surfaceprop" "metal"
}

Download VTFEdit. use google.

  1. Open your image using VTFEdit.
  2. Save it in hldm/hl2/materials/custom as “porno_shop_sign”
  3. Go to the Tools tab in VTFEdit, and click “Create VMT”
  4. Choose your settings. (surface, type of materials, shit like that. Its gives you a list to choose from in the last tab of the window that pops up.)
  5. Save the VMT in the same place you saved the VTF. (hldm/hl2/materials/custom as “porno_shop_sign”)
  6. Open source SDK and run Hammer Editor (if SDK was already opened, close it and open it again), search for “custom” when you click “Browse materials” and your texture should appear.

I had an idea that the problem was with VTF edit and it wasn’t saving my edits, so I opened it in notepad and now it works. Thank you, everyone that provided help!

are u doing it with ctrl+s? use the File Menu

I was doing both.

Also, the texture is showing in hammer, but it’s still the checkerboard in Gmod. Any ideas?

You have to either Pakrat the texture with your map or copy over your custom folder to your garrysmod/materials folder.

Probably the second, I forgot to update that. Thanks.