Problems with fast download.

Well. Ive been dealing with this problem since I bought my Garry’s Mod servers.
My problem is as follows:

I have custom gamemodes, (darkrp, and TTT) and I installed them to my server as per instructions. I updated my fast download, and tried to go on with my computer. I got a Lua cache not found error combined with a GAMEMODE NOT LOADED error. I have tried everything, including downloading the cache from the server, unzipping these and uploading the unzipped dua files to the httpredirect/cache folder of my server. This has not worked. I made sure cl_allowupload and cl_allowdownload are enabled, and have updated my fast download over and over and over. The only way this works is if I download the addon to my computer before connecting. This problem is extremely irritating, as it should be as simple as uploading and updating.
Help is appreciated.

well i have the exact same trouble i am also having great difficulty with an
resource.AddFile script. It seems that the recent garrysmod updates have broken the downloading. Please can someone help usÉ

Anyone?

disable fastdl then try it

How to do would be helpful…

[editline]03:37AM[/editline]

I have the same problem, except I’m the one joining servers. It doesn’t download gamemodes or addons from the server because the server is “misconfigured.”

Your download URL must be http and look something like this:

sv_downloadurl “http://www.mysite.com/fastdl/garrysmod/

Make sure you upload your cache file to http://www.mysite.com/fastdl/garrysmod/cache

Also, you should only have 1 cache file, not multiple. If files are being created in cache/dua then your server is not updated.

thats what i did but now the custom files still dont download so how did that resolve anything.