Problems with GMod Update 75 or other recent updates? Post here.

Keep any issues as a result of the update here please

I haven’t launched Gmod yet. What should I expect?

The main problem was the fact that there is a screen error spam in the console whenever the tool gun is pulled out. It seems to be a conflict with wire, no matter if you SVN updated or not it continues to spam. This applies to everyone on my friends list having the same exact problem, im not the only one.

Removing parented wire components has a 80% chance of crashing your game or if online, the server.

I can’t launch single player mode and I can’t create multiplayer.
The toturial says navigation to web page cancelled.

I can load maps in console but that is very annoying and I get a crap load of lua errors
When I press single player I here the usual beeping sound but nothing appears and when I look in console I see this:

unknown command Menu_singleplayer
unknown command Menu_gmodsettings
ETC

Please Fix!!!9

Jakero, i don’t think many others have that problem, i know i don’t…

Has anyone else actually investigated the - wire/client/toolscreen.lua:23: attempt to call upvalue ‘_ViewModelDrawn’ - error? I just did and it seems that the material in question that the lau is looking for is no longer on my computer… Can some one else confirm this please?

Umm, about 3 duplicates of each server on the list for me.

Yep. Specifically, my Play Singleplayer button is borked to hell. After reviewing the issue is seems that this error only occurs on 64 bit procs, though not necessarilly 64bit OS’s(I run W7U 32bit OEM, though my processor is 64bit.)

I’m having this same problem, and it’s happening recently so I’m guessing it’s the update.

wiremods giving me errors updated today aswell

the Toolgun thing… hate to burst whoever’s bubble it is but I deleted wiremod, restarted steam, started a SP game (yes my single player works) and the toolgun thing STILL happens.

yeah, that’s because of garry’s toolgun too. it’s not just wiremod. both the wiremod and standard toolgun’s lua point to the same file, that is missing… maybe someone who hasn’t updated could upload the material file?

Custom background that worked with the previous update now doesn’t wanna load. Everything is where it should be though.

Okay, well i haven’t even noticed a background change. I have to admit that i’m new to lua coding though, so i’ll take your word for it…

I noticed the background change, also the Toolgun error. I also can’t seem to spawn as many things as I used to.

I also had a random crash earlier that, this time, was not even slightly related to physics lag. Which is usually the case for me. :sweatdrop:

oaky, so i’m looking through the gcf atm, and i’m missing the whole models folder from gmod… yet everything still renders. i’m gonna reinstall it and see if that works, otherwise will look into this a bit closer…

Edit- i’m looking through the gcf, it has the models folder. but my gmod folder doesn’t…

[editline]10:20PM[/editline]

Okay, so looking through my gcf, there’s a whole butt load of files in there which aren’t in my gmod folder. Now i’m not entirely sure how gcf’s work, so maybe they don’t all need to be copied? anyone?

[editline]10:51PM[/editline]

That’s interesting, i just did a fresh install of garry’s mod. and it only extracted around 60mb of files out of a 200mb gcf. but the game still launched, and here’s the thing; only a few of the menu buttons worked… testing again now after extracting the whole gcf.
Me thinkies that garry has just broken the gcf…

Im playing gmod At this moment, and I’ve found that the Toolgun spam only occurs when your in firstperson. I decided to try third to see what I’d get et viola, no spam. So I’m thinking it has something to do with firstperson rendering of the tool gun.

I hope this helps Garry somehow.

I get loads of lua errors when using ADV_Duplicator



wire/client/toolscreen.lua:23: attempt to call upvalue '_ViewModelDrawn' (a nil value)
wire/client/toolscreen.lua:23: attempt to call upvalue '_ViewModelDrawn' (a nil value)
wire/client/toolscreen.lua:23: attempt to call upvalue '_ViewModelDrawn' (a nil value)
wire/client/toolscreen.lua:23: attempt to call upvalue '_ViewModelDrawn' (a nil value)


That’s what the lua error is saying, it’s trying to override a function that ceases to exist. Imagine me looking for a key to a door that no longer used keys.

http://www.garry.tv/?p=1510

Is there any way to disable them with a console command so they wouldn’t show on the screen ?

So it turns out it is just wiremod related… goodnight:/