Problems with GMod Update 75 or other recent updates? Post here.

I’ve no problems with my singleplayer button despite having both 64bit CPU and OS (i7 920 and Win7) but these problems made me stop playing GMod till they’re fixed.

Ugly fonts:

http://img715.imageshack.us/img715/8566/uglyfonts.jpg

More ugly fonts:

http://img214.imageshack.us/img214/843/uglyfonts2.jpg

Also:

http://img717.imageshack.us/img717/6954/uglyfonts3.jpg

Hello everyone, first time poster. I have the same problem that 6502x86 have. 64bit cpu (E6400, very old:P ) and Windows 7 Ult. 32bits. The singleplayer button doesn’t work:/

Heh, it seems I made an accurate guess. :3:

Yeah my friend is having the problem in which he can’t use almost all the buttons on the main menu, so he cant play with us and he bought Garry’s mod 2 days ago, he is pretty pissed…

Can’t play Singplayer or go into the gmod options, and i just reformatted into Windows 7 32bit

Ok.
I tested GMOD, with the last update, and:

  • I have the same problem (lots of errors with the tool gun)
  • The single player button works fine (i have a AMD Phenom II 920)
  • The game don’t crash with the “Userful comic props”

I don’t tested it online.

Hi there i am also having the issue with the main menu not working i get a bleep when i press the buttons but nothing happens tried reinstalling but no help and verifying the files says that there are no problems. the only menu buttons that work are the settings menu and join multiplayer. i only purchased Gmod last night so am not sure if this is an issue with the recent update or not please help with a fix or workaround for this

(edit - forgot to mention that i’m running on Windows vista 32bit so not sure if this is exclusively due to 64 bit systems as others have suggested)

None of the commands I set on my autoexec.cfg work. Including aliases. I have to remake them from memory in the console, which is the exact thing I used autoexec to prevent. |:

i have the wire/client lua error and ugly fonts to… and about the buttons not working, try clicking under them, and fixing resolution, resolution changes do this

I would like to say that I’m also having the same problem as this!

"I can’t launch single player mode and I can’t create multiplayer.
The toturial says navigation to web page cancelled.

I can load maps in console but that is very annoying and I get a crap load of lua errors
When I press single player I here the usual beeping sound but nothing appears and when I look in console I see this:

unknown command Menu_singleplayer
unknown command Menu_gmodsettings
ETC

Please Fix!!!9"

Only thing is I’m using a 32-bit OS on a 32-bit processor. >_>\

Also running Windows XP Pro just bought Gmod yesterday, little pissed but I’m sure it’ll get fixed… it better get fixed that is…

This is what my gmod 10 says when I first open it up. I didn’t even go into a server. Sorry I couldn’t put it in a text box, don’t know how.
Mounting hl2… OK
Mounting ep2… OK
Mounting tf… OK
Mounting cstrike… OK
Mounting dod… OK
Mounting episodic… OK
Mounting hl2mp… OK
Mounting portal… OK
Mounting lostcoast… Disabled
Mounting hl1… Not Mounting hl1 (no access)
No permission
Mounting hl1mp… Not Mounting hl1mp (no access)
No permission
Mounting zeno_clash… Not Mounting zeno_clash (no access)
No permission
Error, bad server command sv_allow_voice_from_file 0
Parent cvar in server.dll not allowed (sk_apc_missile_damage)
Garry’s Mod client.dll Build #073 [Feb 8 2010 19:59:21]
maxplayers set to 128
Steam config directory: c:\program files\steam\steamapps\deadlykid332\garrysmod\platform\config
Convar r_rootlod has conflicting FCVAR_CHEAT flags (child: FCVAR_CHEAT, parent: no FCVAR_CHEAT, parent wins)
Convar r_eyeglintlodpixels has conflicting FCVAR_CHEAT flags (child: FCVAR_CHEAT, parent: no FCVAR_CHEAT, parent wins)
Convar r_skin has conflicting FCVAR_CHEAT flags (child: no FCVAR_CHEAT, parent: FCVAR_CHEAT, parent wins)
Convar mat_softwareskin has conflicting FCVAR_CHEAT flags (child: no FCVAR_CHEAT, parent: FCVAR_CHEAT, parent wins)
Didn’t find particle function render_blobs
Didn’t find particle function render_blobs
Didn’t find particle function render_blobs
Didn’t find particle function render_blobs
Didn’t find particle function render_blobs
Didn’t find particle function render_blobs
Didn’t find particle function render_blobs
Didn’t find particle function lennard jones force
Didn’t find particle function render_blobs
Didn’t find particle function lennard jones force
Didn’t find particle function render_blobs
Didn’t find particle function lennard jones force
Didn’t find particle function render_blobs
Didn’t find particle function lennard jones force
Didn’t find particle function render_blobs
Didn’t find particle function lennard jones force
Didn’t find particle function render_blobs
Didn’t find particle function lennard jones force
Didn’t find particle function render_blobs
Didn’t find particle function lennard jones force
Didn’t find particle function render_blobs
Didn’t find particle function lennard jones force
Didn’t find particle function render_blobs
Didn’t find particle function lennard jones force
Didn’t find particle function render_blobs
Didn’t find particle function lennard jones force
Didn’t find particle function render_blobs
Didn’t find particle function lennard jones force
Didn’t find particle function render_blobs
Didn’t find particle function render_blobs
Didn’t find particle function render_blobs
Didn’t find particle function render_blobs
Didn’t find particle function render_blobs
Didn’t find particle function render_blobs
Didn’t find particle function render_blobs
Didn’t find particle function render_blobs
Didn’t find particle function render_blobs
Didn’t find particle function render_blobs
Didn’t find particle function lennard jones force
Didn’t find particle function render_blobs
Didn’t find particle function render_blobs
Didn’t find particle function lennard jones force
Didn’t find particle function render_blobs
Didn’t find particle function lennard jones force
Didn’t find particle function render_blobs
Didn’t find particle function lennard jones force
Didn’t find particle function render_blobs
Didn’t find particle function lennard jones force
Didn’t find particle function render_blobs
Didn’t find particle function lennard jones force
Didn’t find particle function render_blobs
Didn’t find particle function lennard jones force
Didn’t find particle function render_blobs
Didn’t find particle function lennard jones force
Didn’t find particle function render_blobs
Didn’t find particle function lennard jones force
Didn’t find particle function render_blobs
Didn’t find particle function lennard jones force
Didn’t find particle function Rotation Orient Relative to CP
Didn’t find particle function Rotation Orient Relative to CP
Didn’t find particle function Rotation Orient Relative to CP
Didn’t find particle function Rotation Orient Relative to CP
Didn’t find particle function Rotation Orient Relative to CP
Didn’t find particle function Rotation Orient Relative to CP
Didn’t find particle function Rotation Orient Relative to CP
Didn’t find particle function Rotation Orient Relative to CP
Didn’t find particle function Rotation Orient Relative to CP
Didn’t find particle function Rotation Orient Relative to CP
Didn’t find particle function Rotation Orient Relative to CP
Didn’t find particle function Rotation Orient Relative to CP
Didn’t find particle function Rotation Orient Relative to CP
Didn’t find particle function Rotation Orient Relative to CP
Didn’t find particle function Rotation Orient Relative to CP
Didn’t find particle function Rotation Orient Relative to CP
Didn’t find particle function fade_and_kill
Didn’t find particle function spin
Didn’t find particle function random_radius
Didn’t find particle function random_rotation
Didn’t find particle function initialize_within_sphere
Lua: error loading module ‘sqlite’ from file ‘c:\program files\steam\steamapps\deadlykid332\garrysmod\garrysmod\lua\includes\modules\gm_sqlite.dll’:
The specified module could not be found.

Lua: includes/modules/cookie.lua:2: attempt to index global ‘sql’ (a nil value)
Lua: derma\derma_example.lua:48: attempt to call field ‘RegisterTable’ (a nil value)
Lua: vgui/ContextBase.lua:79: attempt to call field ‘Register’ (a nil value)
Lua: vgui/FingerPoser.lua:199: attempt to call field ‘Register’ (a nil value)
Lua: vgui/FingerVar.lua:196: attempt to call field ‘Register’ (a nil value)
Lua: vgui/ImageButton.lua:4: attempt to call field ‘Register’ (a nil value)
Lua: vgui/ImageCheckBox.lua:76: attempt to call field ‘Register’ (a nil value)
Lua: vgui/Material.lua:80: attempt to call field ‘Register’ (a nil value)
Lua: vgui/MatSelect.lua:230: attempt to call field ‘Register’ (a nil value)
Lua: vgui/PropSelect.lua:151: attempt to call field ‘Register’ (a nil value)
Lua: vgui/SlideBar.lua:246: attempt to call field ‘Register’ (a nil value)
Lua: vgui/ToolQuickSelect.lua:249: attempt to call field ‘Register’ (a nil value)
Lua: vgui/ToolQuickSelect_Properties.lua:124: attempt to call field ‘Register’ (a nil value)
Lua: vgui/vgui_panellist.lua:215: attempt to call field ‘Register’ (a nil value)
Lua: vgui/DAlphaBar.lua:103: attempt to call field ‘Register’ (a nil value)
Lua: derma\derma.lua:57: attempt to call field ‘Register’ (a nil value)
Lua: derma\derma.lua:57: attempt to call field ‘Register’ (a nil value)
Lua: derma\derma.lua:57: attempt to call field ‘Register’ (a nil value)
Lua: derma\derma.lua:57: attempt to call field ‘Register’ (a nil value)
Lua: vgui/DColorCircle.lua:111: attempt to call field ‘Register’ (a nil value)
Lua: vgui/DColorCube.lua:138: attempt to call field ‘Register’ (a nil value)
Lua: vgui/DColoredBox.lua:49: attempt to call field ‘Register’ (a nil value)
Lua: vgui/DColorMixer.lua:236: attempt to call field ‘Register’ (a nil value)
Lua: derma\derma.lua:57: attempt to call field ‘Register’ (a nil value)
Lua: derma\derma.lua:57: attempt to call field ‘Register’ (a nil value)
Lua: derma\derma.lua:57: attempt to call field ‘Register’ (a nil value)
Lua: derma\derma.lua:57: attempt to call field ‘Register’ (a nil value)
Lua: vgui/DHorizontalDivider.lua:36: attempt to call field ‘Register’ (a nil value)
Lua: derma\derma.lua:57: attempt to call field ‘Register’ (a nil value)
Lua: derma\derma.lua:57: attempt to call field ‘Register’ (a nil value)
Lua: derma\derma.lua:57: attempt to call field ‘Register’ (a nil value)
Lua: derma\derma.lua:57: attempt to call field ‘Register’ (a nil value)
Lua: derma\derma.lua:57: attempt to call field ‘Register’ (a nil value)
Lua: derma\derma.lua:57: attempt to call field ‘Register’ (a nil value)
Lua: derma\derma.lua:57: attempt to call field ‘Register’ (a nil value)
Lua: derma\derma.lua:57: attempt to call field ‘Register’ (a nil value)
Lua: derma\derma.lua:57: attempt to call field ‘Register’ (a nil value)
Lua: derma\derma.lua:57: attempt to call field ‘Register’ (a nil value)
Lua: derma\derma.lua:57: attempt to call field ‘Register’ (a nil value)
Lua: derma\derma.lua:57: attempt to call field ‘Register’ (a nil value)
Lua: derma\derma.lua:57: attempt to call field ‘Register’ (a nil value)
Lua: derma\derma.lua:57: attempt to call field ‘Register’ (a nil value)
Lua: derma\derma.lua:57: attempt to call field ‘Register’ (a nil value)
Lua: derma\derma.lua:57: attempt to call field ‘Register’ (a nil value)
Lua: vgui/DNumPad.lua:203: attempt to call field ‘Register’ (a nil value)
Lua: vgui/DNumSlider.lua:171: attempt to call field ‘Copy’ (a nil value)
Lua: derma\derma.lua:57: attempt to call field ‘Register’ (a nil value)
Lua: derma\derma.lua:57: attempt to call field ‘Register’ (a nil value)
Lua: vgui/DPanelSelect.lua:119: attempt to call field ‘Register’ (a nil value)
Lua: derma\derma.lua:57: attempt to call field ‘Register’ (a nil value)
Lua: vgui/DRGBBar.lua:88: attempt to call field ‘Register’ (a nil value)
Lua: derma\derma.lua:57: attempt to call field ‘Register’ (a nil value)
Lua: derma\derma.lua:57: attempt to call field ‘Register’ (a nil value)
Lua: derma\derma.lua:57: attempt to call field ‘Register’ (a nil value)
Lua: derma\derma.lua:57: attempt to call field ‘Register’ (a nil value)
Lua: derma\derma.lua:57: attempt to call field ‘Register’ (a nil value)
Lua: derma\derma.lua:57: attempt to call field ‘Register’ (a nil value)
Lua: derma\derma.lua:57: attempt to call field ‘Register’ (a nil value)
Lua: derma\derma.lua:57: attempt to call field ‘Register’ (a nil value)
Lua: derma\derma.lua:57: attempt to call field ‘Register’ (a nil value)
Lua: derma\derma.lua:57: attempt to call field ‘Register’ (a nil value)
Lua: derma\derma.lua:57: attempt to call field ‘Register’ (a nil value)
Lua: vgui/DVerticalDivider.lua:35: attempt to call field ‘Register’ (a nil value)
Lua: derma\derma.lua:57: attempt to call field ‘Register’ (a nil value)
Lua: vgui/SpawnIcon.lua:155: attempt to call field ‘Register’ (a nil value)
Lua: menu/logo.lua:53: attempt to call field ‘Register’ (a nil value)
Lua: menu/maplist_listview.lua:88: attempt to call field ‘Register’ (a nil value)
Lua: menu\map_favourites.lua:13: attempt to index global ‘cookie’ (a nil value)
Lua: menu\map_icon.lua:159: attempt to call field ‘Register’ (a nil value)
Lua: menu/maplist_iconview.lua:166: attempt to call field ‘Register’ (a nil value)
Lua: menu/startgame.lua:110: attempt to call field ‘Register’ (a nil value)
Lua: menu/map_options.lua:141: attempt to call field ‘Register’ (a nil value)
Lua: menu/singleplayer.lua:78: attempt to call field ‘Register’ (a nil value)
Lua: menu/multiplayer.lua:80: attempt to call field ‘Register’ (a nil value)
Lua: menu/news_bar.lua:79: attempt to call field ‘RegisterTable’ (a nil value)
Lua: menu/loading.lua:10: attempt to call field ‘RegisterFile’ (a nil value)
Lua: menu/settings/settings.lua:11: attempt to call field ‘RegisterFile’ (a nil value)
Lua: menu\ProgressBar.lua:114: attempt to call field ‘Register’ (a nil value)
Lua: menu\achievement_panel.lua:129: attempt to call field ‘Register’ (a nil value)
Lua: menu/achievements.lua:118: attempt to call field ‘Register’ (a nil value)
Garry’s Mod server.dll Build #073 [Feb 8 2010 19:59:20]
maxplayers set to 1
Unknown command “sv_backspeed”
GetAllManifestFiles: Unable to load maplist.txt
— Missing Vgui material vgui/…\vgui\icon_con_high
— Missing Vgui material vgui/…/vgui/icon_con_high.vmt
— Missing Vgui material vgui/…/vgui/icon_con_medium.vmt

Another update from Garrys Blog.

http://www.garry.tv/?p=1515

O.o Ooh a patch.

Fixed now for me, I just got a BSoD on gm_construct while blowing up 6 explosive barrels that have the neon material.

Oh looks like steam updated gmod again. It says it,

-Fixed menu items sometimes not working after yesterday’s update
-Fixed gravity gun crash

Ima go try it out. Rofl @ nightpanther

Edit 10 minutes later:
wire/client/toolscreen.lua:23: attempt to call upvalue ‘_ViewModelDrawn’ (a nil value)

Yup still got that error. Oh well, should get fixed soon anyhooo.

i got this when using the toolgun
autorun/E2toolscreen.lua:123: attempt to call upvalue ‘ViewModelDrawn’ (a nil value)
please help me!!!

You need to wait for the wiremod team to fix it. Great having vanilla GMod. :wink:

Yeah, thanks for laughing. Anyway, it is fixed and I made a cute wallpaper so lets party like its ninnyninny 9!

All I have are the annoying errors and the ugly text.
I’m on a 64 bit, too.

I’m on a x64, will launch and see if I have problems on Vanilla GMod.

Update: Got the different font. No other problems.